Exploring, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

Report control not working on imported tabs in SAS VA.

Reply
New Contributor
Posts: 4

Report control not working on imported tabs in SAS VA.

[ Edited ]

We currently are using SAS VA 7.4

 

We have two people working on different tabs for one SAS VA dashboard, and will merge them all once all tabs are done.  However, it seems once imported tabs from one SAS VA report to another VA dashboard, all report prompt controls will not working on imported tabs. How to overcome this issue?

Image1.JPG

 

PROC Star
Posts: 399

Re: Roport control not working on imported tabs in SAS VA.

Do they have the same data source?

You should be prompted to connect them otherwise.

//Fredrik

New Contributor
Posts: 4

Re: Roport control not working on imported tabs in SAS VA.

There are two set of data sources... existing dashboard are sourced from Table A, as well as Report Prompt Controls... If I simply create a new tab with a different table source(eg. from TABLE B), when I create objects in the new tab, it usually will ask which columns from table A should join with table B, so report wide objects can be used to filter reports in the tab. \

 

In this instance, it hasn't. imported tabs are sourced from table B, the form didn't ask us what columns it should join with table A. Hence, all top report wide controls wont filtering content in the imported tabs.  We have to redo whole tab again, to make it work.

PROC Star
Posts: 399

Re: Roport control not working on imported tabs in SAS VA.

Strange, I don't know how to solve that Smiley Happy

 

Maybe if you change data source for the report prompts, if you have a table with the same structure and switch back and forth might give you the question to link data sources?

 

//Fredrik

New Contributor
Posts: 4

Re: Roport control not working on imported tabs in SAS VA.

It seems a bug in SAS VA 7.4, b'cos v8.1 has no such issue.. Anyway, I end up to redo those two imported tabs again, in order to make it works. once those tabs start from scratch,  I will get to be asked to link relevant columns from table 1(used for report control objects) with table 2(used for tab control objects)...but when tested in v8.1(which my company hasn't bought it, a contractor in our company lucky have access to it), when importing tabs, it will ask straightway which column(s) u wish to link b/w table 1 and table 2.

Super User
Posts: 4,023

Re: Roport control not working on imported tabs in SAS VA.

If you still want to confirm if it is a bug or not open a track with SAS Tech Support. VA 8.x is now starting to move ahead of VA 7.4, with VA 8.3 due out in July. Your company doesn't need to buy VA 8.x, it is a free upgrade from 7.4.

Ask a Question
Discussion stats
  • 5 replies
  • 204 views
  • 0 likes
  • 3 in conversation