Exploring, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

Problems with automatic Year to date function

Reply
Occasional Contributor
Posts: 8

Problems with automatic Year to date function

Hi,

As an easy example to present my problem I have the following very ordinary table showing monthly volumes per year. I would like VA to automatically do the Year to date calculation for me, so that I would not have to manually update the report each month. But when i choose "create and add" and choose "Year to date using date", I see that 2015 looks ok, we have data until february and the total is thus january+february as is shown in the table below. But I see that in 2014, also a part of March is counted into the total. And this means that 2013 and 2014 havemore than Ferbruary in the Year to date total. Which means it is not comparable with 2015. Does anyone know what I'm doing wrong? To clarify, we get new monthly data in the beginning of each month. So we get the whole month of March in the beginning of April.

Capture2.PNG

All answers are highly appreciated.

Kind regards,

Kia

Regular Contributor
Posts: 197

Re: Problems with automatic Year to date function

Hi Kia,

By default YTD will calculate "ToDate".

Right click on the Agg. Measure Volume tonne (YTD) then select edit agg measure. After that change the scope of the period "todate" to "Full".

Thanks,

Teja surapaneni.

Occasional Contributor
Posts: 8

Re: Problems with automatic Year to date function

Thank you for the reply. I tried this solution. But when changing the scope to "Full", the years 2013 and 2014 became full years, but my intention was to get 2013-2014 to be the exact same period as 2015 to be able to compare the YTD 2015 with 2013-2014.


I also tried to change the scope to "To date" and chose February. This gives me the right numbers, but I guess in this case I need to go in each month and change the date manually?

Regular Contributor
Posts: 197

Re: Problems with automatic Year to date function

Hi Kia,

By default YTD shows Till date (Feb), when u change the scop "To date" to "Full" it will shows full year, u dont have any another option to do that you need.

In my End "To date " is works for You.
Regards,
Teja Surapaneni
Ask a Question
Discussion stats
  • 3 replies
  • 361 views
  • 3 likes
  • 2 in conversation