Exploring, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

Permissions issue - Setting up VA

Reply
Occasional Contributor
Posts: 5

Permissions issue - Setting up VA

Pleaase check the log here and suggest me solution.

 

 

cat AutoLoad_2018.06.06_15.00.02.log

NOTE: Log file opened at  Wed, 6 Jun 2018 15:00:02.298

1                                                          The SAS System                              15:00 Wednesday, June 6, 2018

 

NOTE: Unable to open SASUSER.PROFILE. WORK.PROFILE will be opened instead.

NOTE: All profile changes will be lost at the end of the session.

NOTE: Copyright (c) 2002-2012 by SAS Institute Inc., Cary, NC, USA.

NOTE: SAS (r) Proprietary Software 9.4 (TS1M3)

      Licensed to HP/ KS DEPT FOR HEALTH & ENVIRONMENT-PRODUCTION, Site 70193936.

NOTE: This session is executing on the Linux 2.6.32-696.16.1.el6.x86_64 (LIN X64) platform.

 

 

 

NOTE: Additional host information:

 

Linux LIN X64 2.6.32-696.16.1.el6.x86_64 #1 SMP Sun Oct 8 09:45:56 EDT 2017 x86_64 Red Hat Enterprise Linux Server release 6.8

      (Santiago)

 

You are running SAS 9. Some SAS 8 files will be automatically converted

by the V9 engine; others are incompatible.  Please see

http://support.sas.com/rnd/migration/planning/platform/64bit.html

 

PROC MIGRATE will preserve current SAS file attributes and is

recommended for converting all your SAS libraries from any

SAS 8 release to SAS 9.  For details and examples, please see

http://support.sas.com/rnd/migration/index.html

 

 

This message is contained in the SAS news file, and is presented upon

initialization.  Edit the file "news" in the "misc/base" directory to

display site-specific news and information in the program log.

The command line option "-nonews" will prevent this display.

 

 

 

 

NOTE: SAS initialization used:

      real time           0.14 seconds

      cpu time            0.03 seconds

 

WARNING: The library sashelp cannot be assigned. The metadata for this library was probably created with the pre-assigned library

         template. This library cannot be pre-assigned using metadata.

NOTE: Libref SASDATA successfully assigned from logical server.

NOTE: Libref valib successfully assigned from logical server.

WARNING: Libref sashelp may not have assigned correctly from logical server.

 

NOTE: AUTOEXEC processing beginning; file is /sso/biconfig/940/Lev1/SASVA/appserver_autoexec.sas.

 

 

NOTE: AUTOEXEC processing completed.

 

1          /*

2           * AutoLoad

3           *

4           * Purpose: Synchronizes SAS data sets placed in a single disk location with

5           *                   a single LASR Analytic Server library defined in metadata.

6           *

7           */

8

9          /* Set the name of the LASR library to which to Auto Load */

10         %LET AL_META_LASRLIB=Visual Analytics LASR;

11

2                                                          The SAS System                              15:00 Wednesday, June 6, 2018

 

12         /* Include and execute main AutoLoad functionality */

13         %LET

13       ! INCLUDELOC=/sso/sfw/sas/940/SASVisualAnalyticsHighPerformanceConfiguration/7.3/Config/Deployment/Code/AutoLoad/include;

14

15         /* ------- No edits necessary below this line -------- */

16         filename inclib "&INCLUDELOC.";

17         %include inclib ( AutoLoadMain.sas );

3832       %AutoLoadMain;

VA.AutoLoad.Location =/kms/warehouse/default/vaautoload/VALIBLA

 

va.monitoringPath=/sso/biconfig/940/Lev1/Applications/SASVisualAnalytics/VisualAnalyticsAdministrator/Monitoring

NOTE: DATA statement used (Total process time):

      real time           0.29 seconds

      cpu time            0.12 seconds

 

 

 

NOTE: The file

      "/sso/biconfig/940/Lev1/Applications/SASVisualAnalytics/VisualAnalyticsAdministrator/Monitoring/PIDs/autoload_VisualAnalyticsL

      ASR.pid" is:

 

      Filename=/sso/biconfig/940/Lev1/Applications/SASVisualAnalytics/VisualAnalyticsAdministrator/Monitoring/PIDs/autoload_VisualAn

      alyticsLASR.pid,

      Owner Name=lasradm,Group Name=kmsuser,

      Access Permission=-rw-rw-rw-,

      Last Modified=06Jun2018:15:00:03

 

NOTE: 1 record was written to the file

      "/sso/biconfig/940/Lev1/Applications/SASVisualAnalytics/VisualAnalyticsAdministrator/Monitoring/PIDs/autoload_VisualAnalyticsL

      ASR.pid".

      The minimum record length was 4.

      The maximum record length was 4.

NOTE: DATA statement used (Total process time):

      real time           0.00 seconds

      cpu time            0.00 seconds

 

 

NOTE: Libref DBLOG was successfully assigned as follows:

      Engine:        BASE

      Physical Name: /kms/warehouse/default/vaautoload/VALIBLA/Logs

NOTE: LASR Auto Load 7.2

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

NOTE: Task Name: AUTOLOAD

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

NOTE: Process ID: 9500

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

NOTE: Configuration Settings:

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

NOTE: METASERVER=usolglkxks062.xks.dcs-usps.com

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

NOTE: METAPORT=8561

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

NOTE: METAREPOSITORY="Foundation"

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

NOTE: METAUSER=

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

NOTE: METAPASS=XXXXXXXX

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

3                                                          The SAS System                              15:00 Wednesday, June 6, 2018

 

NOTE: LIBRARY=Visual Analytics LASR

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

ERROR: LASR Auto Load either cannot find Visual Analytics LASR library, or the library is not enabled for auto load.

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

ERROR: Check the following:

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

ERROR: 1- Ensure metadata server, port, and repository are set correctly

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

ERROR: 2- Ensure metadata user and metadata password are set correctly

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

ERROR: 3- Ensure library exists, has a unique name, and has VA.AutoLoad.Enabled extended attribute set to "Yes".

ERROR: User does not have appropriate authorization level for file DBLOG.AUTOLOAD.DATA.

 

ERROR: Errors printed on pages 2,3.

 

NOTE: SAS Institute Inc., SAS Campus Drive, Cary, NC USA 27513-2414

NOTE: The SAS System used:

      real time           1.04 seconds

      cpu time            0.46 seconds

 

 

NOTE: Log file closing at  Wed, 6 Jun 2018 15:00:03.328

 

PROC Star
Posts: 391

Re: Permissions issue - Setting up VA

Looks like the authorization is wrong for the user you are using:

 

I think the physical path (/kms/warehouse/default/vaautoload/VALIBLA/Logs) have wrong permissions or the libname in metadata.

I would start with the physical path and grant rwxrwxrwx to test it.

If that doesn't work I would grant RM, WM, R, W to the libname (for SASUSERS) and test again.

//Fredrik

Occasional Contributor
Posts: 5

Re: Permissions issue - Setting up VA

wHICH FILE/FOLDER NEED TO BE GIVEN RWXRWXRWX PERMISSIONS? IS IT VALIBLA...

PROC Star
Posts: 391

Re: Permissions issue - Setting up VA

I rather sure it is a base libname Smiley Happy

 

NOTE: Libref DBLOG was successfully assigned as follows:

      Engine:        BASE

      Physical Name: /kms/warehouse/default/vaautoload/VALIBLA/Logs

 

Check the physical path (/kms/warehouse/default/vaautoload/VALIBLA/Logs) or the libname DBLOG in metadata.

 

//Fredrik

Occasional Contributor
Posts: 5

Re: Permissions issue - Setting up VA

Where to fine DBLOG Library? is it in SMC...

Trusted Advisor
Posts: 1,839

Re: Permissions issue - Setting up VA

Hi @SarathP,

 

it brings my attention the fact that METAUSER variable is empty (and I guess password would be empty too).

 

  Filename=/sso/biconfig/940/Lev1/Applications/SASVisualAnalytics/VisualAnalyticsAdministrator/Monitoring/PIDs/autoload_VisualAn

      alyticsLASR.pid,

      Owner Name=lasradm,Group Name=kmsuser,

      Access Permission=-rw-rw-rw-,

      Last Modified=06Jun2018:15:00:03

I see you are running the job with the OS user lasradm (and it is part of a certain group).

I suppose lasradm is part of several groups (1 primary and several secondary groups) and kmuser is the primary group... but the "sas" group should be its primary OS group. Can you ensure this?

 

Also, I expect lasradm should be a SAS (metadata) user, or an account for a SAS (metadata) group. If not, please do so.

And a couple of counsiderations:

  • If lasradm is a SAS user, then it should be able to run.
  • If lasradm is an account in a SAS group (and you need the password written in this account), then, you would need to schedule the autoload not with lasradm, but with a SAS (metadata & OS) user that is part of this group. The reason is that group accounts in metadata are not allowed to log in to the SAS metadata, because of good reasons: which user would it be? Accounts in groups are more commonly named outbound connections.

As last tip: while not a best practice and not supported by SAS Technical Support (bear this in mind), you can always overrule the default connection to metadata in the Autoload script (SAS Code), by providing yours

options metapass="sasuser1"
        metaport=8561
        metarepository="Foundation"
        metaserver="a123.us.company.com"
        metauser="myuserid";

http://documentation.sas.com/?docsetId=lrmeta&docsetTarget=n03ph3v01d4e7en1n0v7wm8o3yiu.htm&docsetVe...

 

Then, you can control the OS user that runs towards the filesystem, and the SAS user that connects to the metadata folders, and control the permissions on the folders on each system (Linux and SAS)

 

Hope it helps.

Occasional Contributor
Posts: 5

Re: Permissions issue - Setting up VA

Posted in reply to JuanS_OCS

LASRADM IS SERVICE ACCOUNT,IT IS USED TO SCHEDULE CRON JOB FOR AUTOLOAD SCRIPT

Trusted Advisor
Posts: 1,839

Re: Permissions issue - Setting up VA

ok, it is good @SarathP. Did you had the chance to check all the others items as recommended above by @FredrikE and myself?

 

Case this is out of your skills scope/payroll, I would like to advise you to contact SAS (Technical Support, Consulting services or a especialized partner), so they can help you in.

SAS Employee
Posts: 547

Re: Permissions issue - Setting up VA

@SarathP,

 

Please run these two commands and show me the output:

 

ls -ld /kms/warehouse/default/vaautoload/VALIBLA/Logs/autoload.sas7bdat
id <ID_OF_THE_USER_WHO_STARTS_RUNSAS.SH>
Occasional Contributor
Posts: 5

Re: Permissions issue - Setting up VA

ls -ld /kms/warehouse/default/vaautoload/VALIBLA/Logs/autoload.sas7bdat

-rw-r--r--. 1 kmsowner sasapp 131072 Jul  9 10:15 /kms/warehouse/default/vaautoload/VALIBLA/Logs/autoload.sas7bdat

 

id lasradm

uid=784(lasradm) gid=604(kmsuser) groups=604(kmsuser),602(sasapp

SAS Employee
Posts: 547

Re: Permissions issue - Setting up VA

@SarathP,

 

Change the ownership information on that file:

sudo chown lasradm:lasradm /kms/warehouse/default/vaautoload/VALIBLA/Logs/autoload.sas7bdat

Then try to start the autoloading again.

Ask a Question
Discussion stats
  • 10 replies
  • 294 views
  • 2 likes
  • 4 in conversation