Exploring, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

LASR service not starting after Red Hat Upgrade

Accepted Solution Solved
Reply
New Contributor
Posts: 3
Accepted Solution

LASR service not starting after Red Hat Upgrade

After the Red Hat patch RHEL 7.4 our Linux Boxes, the LASR Server stopped working and wouldn't come up.

 

ERROR: A connection to the LASR Analytic Server on 'xxxxxxx.yyyy.zzzz', port 10011, could not be made. Make sure that the

       host and port are correctly specified, that you are attempting to connect to a LASR Analytic Server of the correct vintage,

       and that the server is still running.

ERROR: Libref LASRTEST is not assigned.

ERROR: Error in the LIBNAME statement.

ERROR: Could not start LASR server.  Processing cancelled.

 

In this security patch some ciphers and algorithms were deprecated in the openSSH, causing some SSH Clients to fail to authenticate.

SAS LASR uses its own ssh (tkssh) client to communicate with other nodes

 

 

[/sasbin/SASFoundation/9.4/dbcs/utilities/bin]
 ./tkssh worker01
FATAL ERROR: expected key exchange group packet from server

 

 


Accepted Solutions
Solution
‎08-23-2017 09:41 PM
New Contributor
Posts: 3

Re: LASR service not starting after Red Hat Upgrade

[ Edited ]
Posted in reply to LucianoMachado

To fix the issue it is necessary to tell SAS to use the OS ssh Client, by changing sasv9_local.cfg adding the following

 

-SET GRIDRSHCOMMAND "/usr/bin/ssh -q -o StrictHostKeyChecking=no"

 

[/sasbin/SASFoundation/9.4]
$ vi sasv9_local.cfg
-MEMSIZE 128G
-SORTSIZE 64G
-BUFSIZE 64K
-UBUFSIZE 64K
-IBUFSIZE 32767
-BUFNO 10
-UBUFNO 10
-IBUFNO 10
-ALIGNSASIOFILES
-SET GRIDRSHCOMMAND "/usr/bin/ssh -q -o StrictHostKeyChecking=no"

View solution in original post


All Replies
Solution
‎08-23-2017 09:41 PM
New Contributor
Posts: 3

Re: LASR service not starting after Red Hat Upgrade

[ Edited ]
Posted in reply to LucianoMachado

To fix the issue it is necessary to tell SAS to use the OS ssh Client, by changing sasv9_local.cfg adding the following

 

-SET GRIDRSHCOMMAND "/usr/bin/ssh -q -o StrictHostKeyChecking=no"

 

[/sasbin/SASFoundation/9.4]
$ vi sasv9_local.cfg
-MEMSIZE 128G
-SORTSIZE 64G
-BUFSIZE 64K
-UBUFSIZE 64K
-IBUFSIZE 32767
-BUFNO 10
-UBUFNO 10
-IBUFNO 10
-ALIGNSASIOFILES
-SET GRIDRSHCOMMAND "/usr/bin/ssh -q -o StrictHostKeyChecking=no"
SAS Employee
Posts: 318

Re: LASR service not starting after Red Hat Upgrade

Posted in reply to LucianoMachado

@LucianoMachado,

 

The root cause of this problem is that TKSSH is not compatible with OpenSSH that ships with RHEL 7.4. You have to use an external SSH client as you said above. I've found this problem almost immediately after the release of RHEL 7.4.

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 368 views
  • 0 likes
  • 2 in conversation