Exploring, modeling, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

Error in SAS VA

Reply
Regular Contributor
Posts: 212

Error in SAS VA

Hi mates,

 

I'm trying to load a new table in Visual analytics and i'm getting the following errors:

 

-------------- Task Summary --------------
SUCCESS (SASJob PreCode)
ERRORS (Load Table)
----------------------------------------------
ERROR: The HDFS file has blocks stored on machines that are not included in this server.
ERROR: The HDFS file has blocks stored on machines that are not included in this server.
ERROR: Creation of the in-memory image for HDFS file '/vapublic/relatorio_relacionamento' failed. The file has not been added to
the LASR Analytic Server.

 

These errors started after they restarted the services.

 

Why is that happening ?

What is the solution for this issue ?

 

Thanks in advance

Grand Advisor
Posts: 9,748

Re: Error in SAS VA


DartibaliRodrigo wrote:

 

These errors started after they restarted the services.

 

 


When something is "restarted" or similar check whether there were any errors reported related to drives not being available or if a configuration change was made that affects drive mappings and such.

 

My guess is someone forgot to include a previous setting when restarting.

Occasional Contributor
Posts: 8

Re: Error in SAS VA

Hi, i have the same problem. Any suggestion to solve this????

Occasional Contributor
Posts: 8

Re: Error in SAS VA

Specifically, while we are attempting to load the table from hadoop to lasr server whe have the following problem:

 

ERROR: Communication failure between LASR Analytic Server and client application.
ERROR: Creation of the in-memory image for HDFS file '/hps/table_va' failed. The file has not been added to the LASR
Analytic Server.

 

A different problem exists also when we try to unload the same table from hadoop:

 

ERROR: The table HPS.table_VA could not be located in the LASR Analytic Server image.

 

These problems happen not for all the tables we are loading. 

We run each program by sh in a Linux distributed environment.

 

Occasional Contributor
Posts: 8

Re: Error in SAS VA

I made a mistake:

 

A different problem exists also when we try to unload the same table from hadoop Lasr Server:

 

ERROR: The table HPS.table_VA could not be located in the LASR Analytic Server image.

 

I read also this post about "trying to LOAD a table from ODBC Library" to LASR :

https://communities.sas.com/t5/SAS-Visual-Analytics/SAS-LASR-Table-Loading-Error/m-p/265374#M3966

 

The solution is:

"This error is caused when the user is trying to load a table whose table structure is not identical to its earlier version".

 

If it is the solution, how can i unload this table forcedly?

 

Regular Contributor
Posts: 212

Re: Error in SAS VA

Hi guys.

 

Sorry, forgot to answer this.

 

We still having troubles with this.

 

It is the cause of earlier version of table, cause we've updated the table in the metadata and in data builder.

 

Att

Post a Question
Discussion Stats
  • 5 replies
  • 544 views
  • 0 likes
  • 3 in conversation