Exploring, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

ERROR: Public LASR Analytics Server - No mapping between account names and security IDs

Accepted Solution Solved
Reply
Contributor
Posts: 73
Accepted Solution

ERROR: Public LASR Analytics Server - No mapping between account names and security IDs

Hi!

 

When I try to start the Public LASR Analytics Server I get this error:

 

-1 -------------- Task Summary -------------- SUCCESS (SASJob PreCode) ERRORS (Store Process ID) ------- --------------------------------------- ERROR: No mapping between account names and security IDs was done ERROR: Setting permissions on "D: \ SAS \ ​​Config \ Lev1 \ Applications \ SASVisualAnalytics \ VisualAnalyticsAdministrator \ Monitoring \ PIDs \ smp_medpro_10031.pid" failed. ERROR: I / O failure.

 

Anyone knows what's going on?

 

Kind regards


Accepted Solutions
Solution
‎11-13-2017 08:16 AM
SAS Employee
Posts: 547

Re: ERROR: Public LASR Analytics Server - No mapping between account names and security IDs

Posted in reply to JuanDaniel

@JuanDaniel,

 

Make sure that the user who tries to start the LASR server has sufficient permissions to folder D:\SAS\​​Config\Lev1\Applications\SASVisualAnalytics\VisualAnalyticsAdministrator\Monitoring\PIDs\. Also, try to remove D:\SAS \​​Config\Lev1\Applications\SASVisualAnalytics\VisualAnalyticsAdministrator\Monitoring\PIDs\smp_medpro_10031.pid before next attempt, the file might be corrupted.

View solution in original post


All Replies
Solution
‎11-13-2017 08:16 AM
SAS Employee
Posts: 547

Re: ERROR: Public LASR Analytics Server - No mapping between account names and security IDs

Posted in reply to JuanDaniel

@JuanDaniel,

 

Make sure that the user who tries to start the LASR server has sufficient permissions to folder D:\SAS\​​Config\Lev1\Applications\SASVisualAnalytics\VisualAnalyticsAdministrator\Monitoring\PIDs\. Also, try to remove D:\SAS \​​Config\Lev1\Applications\SASVisualAnalytics\VisualAnalyticsAdministrator\Monitoring\PIDs\smp_medpro_10031.pid before next attempt, the file might be corrupted.

Contributor
Posts: 73

Re: ERROR: Public LASR Analytics Server - No mapping between account names and security IDs

@alexal Thx  for the response.

 

I removed the file and I restarted the server and It's works!

 

Kind regards

 

 

SAS Employee
Posts: 547

Re: ERROR: Public LASR Analytics Server - No mapping between account names and security IDs

Posted in reply to JuanDaniel

@JuanDaniel,

 

You are welcome! I have an explanation for you about what happened. When a non-distributed LASR server is started interactively by the administrator by clicking start in VA Admin or by using autostart, two additional SAS components are used:

 

  • The job execution service in the SAS middle tier.
  • A SAS Object Spawner in the server tier.

These two components are used to start a workspace server in the server tier. The workspace server submits the code that starts the non-distributed server and it remains running. The execution sequence creates a dependency between a SAS LASR Analytic Server, the middle tier, and the SAS Object Spawner. If any of the following are stopped or restarted, a non-distributed server can stop or become unresponsive:

 

  • the SAS Web Application Server (SASServern_m)
  • the related instance of the job execution service on the SAS Web Application Server
  • the SAS Object Spawner

Next time, before restarting any of those components, stop your LASR servers...

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 357 views
  • 2 likes
  • 2 in conversation