Exploring, modeling, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

Can't See Datasets on Both SASApp and SASAppVA (Just See on SASApp)

Accepted Solution Solved
Reply
Super Contributor
Posts: 381
Accepted Solution

Can't See Datasets on Both SASApp and SASAppVA (Just See on SASApp)

[ Edited ]

Hello everyone,

 

I want to generate my tables on both SASApp and SASAppVA which I created on Enterprise Guide.

 

1-) I created a library as "Batch" on SAS Management Console.

 

2-) Then I selected "Assing" tab and chose both SASApp and SASAppVA.

 

3-) On Options tab, I gave libref as "Batch" then I navigate different path for both SASAppVA and SASApp from Path Specification and I selected "Library is Pre-Assigned" to see libraries on EG as default.

 

4-) From Enterprise Guide, when I execute my code into my "Batch" library, I just can see the outputs under the SASApp server, I can see nothing under the SASAppVA server. I can't see anything on SASAppVA  for "Batch" libary.

 

5-) When I go to the servers from FileZilla, I can see the physical tables on SASApp server but I can't see nothing on SASAppVA.

 

I would like to learn why is the reason? Why I can't see the tables under SASAppVA server?

 

My purpose is that to see the outputs on both SASApp and SASAppVA whenever I exceute my code into my "Batch" library.

 

Thank you.


Accepted Solutions
Solution
‎05-29-2016 08:35 AM
Respected Advisor
Posts: 3,107

Re: Can't See Datasets on Both SASApp and SASAppVA (Just See on SASApp)

When EG connects, it can connect to more than one application server, however, when you execute SAS code, or EG projects, the workspace server (or stored process server) instance is only running on ONE app server, regardless how many app servers you have assigned your library to.  You will have to select specific server to run your process. In your case, the SASapp is the default.

View solution in original post


All Replies
Solution
‎05-29-2016 08:35 AM
Respected Advisor
Posts: 3,107

Re: Can't See Datasets on Both SASApp and SASAppVA (Just See on SASApp)

When EG connects, it can connect to more than one application server, however, when you execute SAS code, or EG projects, the workspace server (or stored process server) instance is only running on ONE app server, regardless how many app servers you have assigned your library to.  You will have to select specific server to run your process. In your case, the SASapp is the default.

Super Contributor
Posts: 381

Re: Can't See Datasets on Both SASApp and SASAppVA (Just See on SASApp)

Thank you for the information. 

 

So how can I set the SASAppVA as default server for Enterprise Guide?

 

Furthermore, I created a new library as "VALIB" just for SASAppVA but I can see this library as "SASAppVA - Valib" under the SASAppVA server on Enterprise Guide. Do you have an idea about this?

 

Thank you,

 

Can Lütfü Yılmazer

Super Contributor
Posts: 381

Re: Can't See Datasets on Both SASApp and SASAppVA (Just See on SASApp)

Okay, I can select the SASAppVA but is it possible to biring this selection being default?

Respected Advisor
Posts: 3,107

Re: Can't See Datasets on Both SASApp and SASAppVA (Just See on SASApp)

I am not sure if you can do that within EG. I don't have admin privilege in my current position so I can't try it out. If my memory servers me true, when you deploy SAS system, the very first application server installed becomes the default in the case of multiple app servers. I would assume you can modify that after the fact using Management console. Check with your SAS admin, and hopefully SAS admin here online will help you out.

 

Good luck,

Haikuo

Post a Question
Discussion Stats
  • 4 replies
  • 293 views
  • 1 like
  • 2 in conversation