Exploring, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

Autoload stopped working

Reply
Senior User
Posts: 1

Autoload stopped working

Hello all.  I am not the SAS administrator at our organization; I am a content developer.  My goal with this message is to do some legwork in finding possible causes to this issue before speaking with the administrator again.

 

Yesterday I came into work and the "Public LASR Analytics Server" was stopped.  I tried to restart it from the SAS VA 7.3 "Manage Environment" console but had no luck.  This was the morning after the administrator changed a couple of library permissions for me on the server (I have no idea if this is related to my problem).

 

The administrator restarted the server and the "Public LASR Analytics Server" changed to a status of "Running" on the "Manage Environment" console.  Unfortunately, only a handful of the many tables reloaded.  The tables had a status of "Unloaded" and when I tried to reload them I received a "Not processed (not reloadable)" error.  I opened SAS EG and was able to see and access these unloaded tables in the "Autoload" library.  I manually uploaded the tables to the "Public LASR Analytics Server" from SAS EG.  I then went back to SAS VA and refreshed the "Management Environment" to see that the table had, in fact, reloaded.

 

There are two problems.  1) When I create a new dataset in SAS EG and save it to the “Autoload” library, SAS VA does not “see” this dataset and I have to upload it manually.  2)  If I update a dataset in the “Autoload” library, it does not refresh in VA as it did in the past.

 

The "Loaded" column in the "Management Environment" shows the time and date that I manually uploaded the table but there is no information showing that autoload is refreshing the table.  It seems that VA doesn't know that the table has been updated so it doesn't attempt to refresh.  In addition, after the server restart mentioned above, there are several default SAS tables that did not reload and are not reloadable in the “/Shared Data/SAS Visual Analytics/Autoload/EVDMLA” directory like: AUDIT_VISUALANALYTICS, EVENTS, FILEMOUNTS, METADATASRVS, etc.  I'm not sure if this is related to my problem either.

 

Sorry for the long post but I truly appreciate the help.  Is there anything that I can try without the SAS Management Console?  Is there anything I can ask my administrator to check?

SAS Super FREQ
Posts: 556

Re: Autoload stopped working

@ANON4,

If I update a dataset in the “Autoload” library, it does not refresh in VA as it did in the past.
Is there anything I can ask my administrator to check?

Yes, first off the have to check the autoload logs located in Logs/ folder of the autoload scripts directory.

Ask a Question
Discussion stats
  • 1 reply
  • 163 views
  • 0 likes
  • 2 in conversation