Exploring, predicting and reporting with SAS Visual Analytics and SAS Visual Statistics

AutoLoad after https - Linux VA 7.3

Accepted Solution Solved
Reply
Contributor
Posts: 21
Accepted Solution

AutoLoad after https - Linux VA 7.3

Dear SAS communities,

we've succesfully transfered our VA 7.3 app to https on RHEL. But we have problem with AutoLoad script located in 

 

..../Lev1/Applications/SASVisualAnalytics/VisualAnalyticsAdministrator/VALIBLA/runsas.sh\

 

The problem is that AL_SIGNER macro variable is still set to the old one signer with HTTP.

 

LIBREF=VALIBLA
TAG=HPS
SASClientConnection
Port 10011
HOST=xxxxx
SIGNER=http://xxxx:7980/SASLASRAuthorization
ServerComponent LASR Analytic Server - czdotplva1

 

which results into ¨this errror in sas code

ERROR: Unable to connect to Signing Server.

 

Could you please tell me what to change? I already tried manualy change all AL_SIGNER vars to hardcoded https url in

../SASHome/SASVisualAnalyticsHighPerformanceConfiguration/7.3/Config/Deployment/Code/AutoLoad/include

 

, but no luck.

 

Is there any posibility we forgot something in https configuration?

 

 

Thanks!

Miki

 


Accepted Solutions
Solution
‎02-20-2018 10:26 AM
SAS Super FREQ
Posts: 556

Re: AutoLoad after https - Linux VA 7.3

@miki7,

 

First off, please validate that you have changed communication protocol for all objects in SAS Management Console -> Application Management -> Configuration Manager -> SAS Application Infrastructure -> Visual Analytics Services 7.3 -> LASR Authorization Service 7.3 and everything underneath that object. Secondly, right click on the library -> Display LIBNAME statement, what you see there? HTTP or HTTPS? If HTTP, go to Server Manager and select your LASR server. Right-click on the Connection object -> Properties -> Options and click OK. Then check LIBNAME statement again. Has anything changed? If the protocol has been changed to HTTPS, just restart the autoload process.

View solution in original post


All Replies
Solution
‎02-20-2018 10:26 AM
SAS Super FREQ
Posts: 556

Re: AutoLoad after https - Linux VA 7.3

@miki7,

 

First off, please validate that you have changed communication protocol for all objects in SAS Management Console -> Application Management -> Configuration Manager -> SAS Application Infrastructure -> Visual Analytics Services 7.3 -> LASR Authorization Service 7.3 and everything underneath that object. Secondly, right click on the library -> Display LIBNAME statement, what you see there? HTTP or HTTPS? If HTTP, go to Server Manager and select your LASR server. Right-click on the Connection object -> Properties -> Options and click OK. Then check LIBNAME statement again. Has anything changed? If the protocol has been changed to HTTPS, just restart the autoload process.

Contributor
Posts: 21

Re: AutoLoad after https - Linux VA 7.3

Thanks a lot! it worked.

the main problem was in 

" Right-click on the Connection object -> Properties -> Options and click OK" 

I'd never tought that'll be needed to just clickid to propagate this settings.

 

Anyway in SAS MC there was nothing like 

SAS Management Console -> Application Management -> Configuration Manager -> SAS Application Infrastructure -> Visual Analytics Services 7.3 -> LASR Authorization Service 7.3 

 

Is it okay?

SAS Super FREQ
Posts: 556

Re: AutoLoad after https - Linux VA 7.3

@miki7,

 

You are welcome. I'm glad that the problem has been resolved.

Anyway in SAS MC there was nothing like
SAS Management Console -> Application Management -> Configuration Manager -> SAS Application Infrastructure -> Visual Analytics Services 7.3 -> LASR Authorization Service 7.3
Is it okay?


Nope. Make sure that you have connected as an unrestricted user and also, make sure you starting the SAS Management Console directly from the server.

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 189 views
  • 2 likes
  • 2 in conversation