Write and run SAS programs in your web browser

SAS Studio Status check stuck in Initializing after click "Start"

Accepted Solution Solved
Reply
New Contributor ct4
New Contributor
Posts: 2
Accepted Solution

SAS Studio Status check stuck in Initializing after click "Start"

I try to launch SAS STudio after Starting but it gets stucked in Initializing.

 

How to fix this? 

 

thanks,

Ciara


Capture.JPG

Accepted Solutions
Solution
a week ago
SAS Super FREQ
Posts: 391

Re: SAS Studio Status check stuck in Initializing after click "Start"

[ Edited ]

Chrome just released v67, which surfaces an issue in the (Dojo) JavaScript toolkit that SAS Studio uses, preventing SAS Studio from being able to load (just spins "Initializing").

 

For details, see:

https://github.com/kriszyp/xstyle/issues/44

https://github.com/kriszyp/xstyle/issues/56

https://github.com/kriszyp/xstyle/commit/7acb8186ccee813802625ca600eda2e307f9542c#diff-2b85e238ffb30...

 

For now, best to avoid updating Chrome to v67 until this issue is fixed. We are investigating to see if there are any possible workarounds (besides using another browser).

 

Update 6/12/2018: Hot fixes were released today that address this issue for SAS Studio 3.71 (C2L002) and 3.6 (A4R004).

Hot fixes will be made available soon for SAS Studio 3.7 and 4.3. Until then, we recommend using a different browser.

 

Casey

View solution in original post


All Replies
New Contributor ct4
New Contributor
Posts: 2

Re: SAS Studio Status check stuck in Initializing after click "Start"

Forgot to mention that I am using SAS University Edition

Occasional Contributor
Posts: 7

Re: SAS Studio Status check stuck in Initializing after click "Start"

You need to go to the Server running SAS Studio, go the user directory for the user having the issue and rename the SASStudio directory to something like ".old" It creates a new directory.  The problem is something gets corrupt somehow so the user may have to recreate any customizations they built. 

The path is C:\user\appdata\roaming\sas\sasstudio

Occasional Learner
Posts: 1

Re: SAS Studio Status check stuck in Initializing after click "Start"

Posted in reply to OKst8_Emp
Hi,

I have the same problem and I can't find the path you suggested. Actually, under the 'roaming' folder there is no 'sas' folder. Any other idea would be appreciated!
Highlighted
Occasional Contributor
Posts: 7

Re: SAS Studio Status check stuck in Initializing after click "Start"

Make sure you are on the server.  Make sure you go to organize  >> folders and search options >> view >> show hidden files.

 

Let me know if that helps.

New Contributor esu
New Contributor
Posts: 3

Re: SAS Studio Status check stuck in Initializing after click "Start"

Posted in reply to OKst8_Emp

Hi,

 

I am also having this problem, but I my computer is a mac.  What is the equivalent file path on a mac?

 

Thanks,

Emily

Occasional Contributor
Posts: 7

Re: SAS Studio Status check stuck in Initializing after click "Start"

If you are using SAS Studio it must be on a server. Is your Mac acting as a server?
New Contributor esu
New Contributor
Posts: 3

Re: SAS Studio Status check stuck in Initializing after click "Start"

Posted in reply to OKst8_Emp

I don't know -- I am using SAS University Edition, with VirtualBox.  I just followed the instructions on the SAS University Edition to set it up, and it was working fine until recently (and I did not update either SAS University Edition or VirtualBox or make any other changes immediately before it stopped working.)

 

I did discover that it works if I use Safari rather than Chrome, so the problem may actually be browser-specific.  I tried clearing my Chrome cache and cookies, but this did not solve the problem.  I can use Safari for now as a work-around, but Chrome is my usual browser so it would be a lot more convenient for it to work in Chrome.

 

Thank you for your help!

Emily

Occasional Contributor
Posts: 7

Re: SAS Studio Status check stuck in Initializing after click "Start"

Ok, there could be a difference between SAS Studio and the University Edition.  So your problem is the same though...being that you get the spinning "Loading?"

 

What version of iOS are you running on your Mac?

New User
Posts: 2

Re: SAS Studio Status check stuck in Initializing after click "Start"

I have the same problem. On Safari it did not work for me when I used the same kind of path for the SAS University Edition (I am a Mac user with the virtual box installed). Has anyone managed to make it work on Safari? If so - how? What am I doing wrong?

New User
Posts: 1

Re: SAS Studio Status check stuck in Initializing after click "Start"

I have the same problem. Any one knows how to fix it?

Occasional Contributor
Posts: 7

Re: SAS Studio Status check stuck in Initializing after click "Start"

Posted in reply to msaadahmed280

Did you try my fix? 

Regular Learner
Posts: 1

Re: SAS Studio Status check stuck in Initializing after click "Start"

Posted in reply to msaadahmed280

I had the same issue when I tried to run using the chrome. 

Try running the server using the Internet explorer or firefox. It would work. 

Solution
a week ago
SAS Super FREQ
Posts: 391

Re: SAS Studio Status check stuck in Initializing after click "Start"

[ Edited ]

Chrome just released v67, which surfaces an issue in the (Dojo) JavaScript toolkit that SAS Studio uses, preventing SAS Studio from being able to load (just spins "Initializing").

 

For details, see:

https://github.com/kriszyp/xstyle/issues/44

https://github.com/kriszyp/xstyle/issues/56

https://github.com/kriszyp/xstyle/commit/7acb8186ccee813802625ca600eda2e307f9542c#diff-2b85e238ffb30...

 

For now, best to avoid updating Chrome to v67 until this issue is fixed. We are investigating to see if there are any possible workarounds (besides using another browser).

 

Update 6/12/2018: Hot fixes were released today that address this issue for SAS Studio 3.71 (C2L002) and 3.6 (A4R004).

Hot fixes will be made available soon for SAS Studio 3.7 and 4.3. Until then, we recommend using a different browser.

 

Casey

New Contributor esu
New Contributor
Posts: 3

Re: SAS Studio Status check stuck in Initializing after click "Start"

Posted in reply to CaseySmith

Ahhh, this is probably my problem -- Chrome updates automatically so I didn't realize it had updated, but I am indeed running Chrome v67.  Thank you -- this is very helpful!  I'll use another browser until this issue is fixed.

 

Best,

Emily

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 22 replies
  • 1999 views
  • 6 likes
  • 12 in conversation