Write and run SAS programs in your web browser

SAS Code Color not working!

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 5
Accepted Solution

SAS Code Color not working!

I am unable to have color for part of my code. I tried to reset the preference but with no success.

 

So I enclosed the code. I have no idea why the first bach of the code shows the color and the second half of the code is not colored. 

 

I copy pasted on a new program and it shows all the colors. What am I missing here?

 

Thanks,
S


Capture.JPG

Accepted Solutions
Solution
‎07-05-2017 04:20 PM
Super User
Posts: 17,963

Re: SAS Code Color not working!

This just means the browsers being a pain in the a**. Restart your session and you should see it fine. 

Usually this would mean that you have an unclosed quote or comment somewhere, but from what you've shown that doesn't seem likely. I sometimes see this in SAS UE/SAS Studio and a restart usually fixes everything. Yes, it's annoying but a small thing to deal with in the whole scheme of things.

 


SASfreak1 wrote:

I am unable to have color for part of my code. I tried to reset the preference but with no success.

 

So I enclosed the code. I have no idea why the first bach of the code shows the color and the second half of the code is not colored. 

 

I copy pasted on a new program and it shows all the colors. What am I missing here?

 

Thanks,
S


 

View solution in original post


All Replies
Solution
‎07-05-2017 04:20 PM
Super User
Posts: 17,963

Re: SAS Code Color not working!

This just means the browsers being a pain in the a**. Restart your session and you should see it fine. 

Usually this would mean that you have an unclosed quote or comment somewhere, but from what you've shown that doesn't seem likely. I sometimes see this in SAS UE/SAS Studio and a restart usually fixes everything. Yes, it's annoying but a small thing to deal with in the whole scheme of things.

 


SASfreak1 wrote:

I am unable to have color for part of my code. I tried to reset the preference but with no success.

 

So I enclosed the code. I have no idea why the first bach of the code shows the color and the second half of the code is not colored. 

 

I copy pasted on a new program and it shows all the colors. What am I missing here?

 

Thanks,
S


 

Occasional Contributor
Posts: 5

Re: SAS Code Color not working!

Thanks Reeza. Yes for sure it is a pain. It is triggered for no apparent reason too. I can't make it stop i guess. 

SAS Employee
Posts: 40

Re: SAS Code Color not working!

 

Agree with @Reeza that browsers are a pain. :-) but very cool when they behave. 

 

@SASfreak1

What browser and version are you using?

 

What SAS Studio version are you using? 

Occasional Contributor
Posts: 5

Re: SAS Code Color not working!

Chrome V 58.0.3029.110

SAS V 9.04.01M3P062415

SAS Employee
Posts: 40

Re: SAS Code Color not working!

What SAS Studio version....? 3.5? 3.6? University Edition? This info should be in the About dialog.
Occasional Contributor
Posts: 5

Re: SAS Code Color not working!

3.6 Enterprise ed

Occasional Contributor
Posts: 5

Re: SAS Code Color not working!


samdupont wrote:

 

Agree with @Reeza that browsers are a pain. :-) but very cool when they behave. 

 

@SASfreak1

What browser and version are you using?

 

What SAS Studio version are you using? 



Chrome V 58.0.3029.110

SAS V 9.04.01M3P062415

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 7 replies
  • 178 views
  • 0 likes
  • 3 in conversation