Your SAS programs, embedded in web apps and elsewhere

Stored Process output display issue in IDP

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 13
Accepted Solution

Stored Process output display issue in IDP

Hi Friends, I'm facing a problem with stored processes in IDP, it doesn't displays the output and generating below mentioned errors. Can you please help me. NOTE: Writing HTML Body file: sashtml.htm ERROR: File is in use, /SASCONF/conf93/Lev1/SASApp/sashtml.htm. ERROR: No body file. HTML output will not be created. NOTE: The SAS System stopped processing this step because of errors.
Thanks& Regards,
Rajiv Santosh.

Accepted Solutions
Solution
‎05-12-2016 01:25 AM
Regular Contributor
Posts: 170

Re: Stored Process output display issue in IDP

I think the problem might be that with the STREAM option selected and running on the stored process server in the IDP it defaults to HTML output (ODS HTML), but then you're explicitly trying to use ODS TAGSETS.MSOFFICE2k when the listing is already in use for HTML. 

 

Are you trying to make it create a file that the user downloads?  If so, I believe you need to change your approach a bit.  Check out pages 17-18 of this paper http://support.sas.com/resources/papers/proceedings15/SAS1700-2015.pdf.

 

 

View solution in original post


All Replies
Regular Contributor
Posts: 170

Re: Stored Process output display issue in IDP

Did you select "streaming" as the output type on the execution tab of the stores process?

Are you using the %stpbegin and %stpend macros? I believe if either of these are true and you have any Html ODS statements in your code then it will create a conflict.

Can you share your stored process code?
Occasional Contributor
Posts: 13

Re: Stored Process output display issue in IDP

Hi Timmy,

Stream option is enabled and I used %stpbegin and %stpend in my stored process program. In EG its working fine and generating output, but when I access through with Information delivery portal, it gives me such error msg. Find the screen shots also.

 

Here I've attached my Stored process code. 


Screen Shot 05-02-16 at 05.33 PM.PNG
Thanks& Regards,
Rajiv Santosh.
Solution
‎05-12-2016 01:25 AM
Regular Contributor
Posts: 170

Re: Stored Process output display issue in IDP

I think the problem might be that with the STREAM option selected and running on the stored process server in the IDP it defaults to HTML output (ODS HTML), but then you're explicitly trying to use ODS TAGSETS.MSOFFICE2k when the listing is already in use for HTML. 

 

Are you trying to make it create a file that the user downloads?  If so, I believe you need to change your approach a bit.  Check out pages 17-18 of this paper http://support.sas.com/resources/papers/proceedings15/SAS1700-2015.pdf.

 

 

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 412 views
  • 1 like
  • 2 in conversation