Your SAS programs, embedded in web apps and elsewhere

Stored Process Prompt issue

Reply
Occasional Contributor
Posts: 13

Stored Process Prompt issue

Hi ,
 
We've a problem in stored process excecution. we have selected a dynamic list in one of the prompts, In that the values are not retrieving to display from the selected table of dynamic list. Selected table for dynamic list and other tables used in the stored process belongs to same library. 
 
Key points:
 
we are successfully getting the values list in the prompt only before the exection of using Library with libname statement.
 
If we're not executing the libname statement, before running the storerd process its not poping the list in the prompt.
 
Here I've attached some screenshots and the code used in the stored process. 

Screen Shot 06-16-16 at 05.10 PM.PNGScreen Shot 06-16-16 at 05.11 PM.PNG
Thanks& Regards,
Rajiv Santosh.
Super User
Posts: 6,936

Re: Stored Process Prompt issue

I don't see any code in your screenshots, but I guess you need to define your library in the metadata so that it is automatically assigned by the stored process server.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
Occasional Contributor
Posts: 13

Re: Stored Process Prompt issue

That Library is already registered with Meta data.

Please find the code below we are using.

Thanks& Regards,
Rajiv Santosh.
Super User
Posts: 6,936

Re: Stored Process Prompt issue

To verify that the library definition is not the culprit, I'd create a simple STP that reads data from a dataset in that library (without explicit libname for that library in the STP) and test that.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
Occasional Contributor
Posts: 13

Re: Stored Process Prompt issue

AS per the update from SAS Technical support, To generate the values dynamically, the table used in the prompt should belongs to the same library of other tables used in the program, I already have the program in the same manner, then also it won't work.

May I get any additional information to resolve this issue.

Thanks& Regards,
Rajiv Santosh.
Ask a Question
Discussion stats
  • 4 replies
  • 352 views
  • 0 likes
  • 2 in conversation