Your SAS programs, embedded in web apps and elsewhere

Metadata-defined library (DB2 engine) is not reconnecting after losing con.

Reply
N/A
Posts: 0

Metadata-defined library (DB2 engine) is not reconnecting after losing con.

In SAS Management Console I've defined a new SAS library based on a DB2 engine. This connection works well on WorkSpace servers and Stored Process Servers. Now the following happens:

At night, the DB2 database goes offline for backup reasons. The SP server will lose connection with this database server and the users won't be able to run SP's based on this connection. However, the Metadata server will think the connection is up and running.

There's no way to avoid the database server from going offline, so I need to find a solution to make the SP server automaticly reconnect. By the way, the WorkSpace server doesn't have this kind of problem, because it's automaticly starting a new sas process.

Restarting the SP server or ObjectSpawner with a cronjob wouldn't be the perfect solution, because it will affect the whole organisation. What's next to try?

Tnx in advance
N/A
Posts: 0

Re: Metadata-defined library (DB2 engine) is not reconnecting after losing con.

Hello,


You have to try these 2 solutions:

1) Change the TIME_IDDLE parameter ( something like that) in DB2 to UNLIMITTED.

2) Use CONNECTION=UNIQUE option in the LIBNAME Instruction. The connection will be opened each time you use a table and closed at the end of using table.


Regards,
N/A
Posts: 0

Re: Metadata-defined library (DB2 engine) is not reconnecting after losing con.

I forget the second option in the LIBNAME instruction

2) Use CONNECTION=UNIQUE UTILCONN_TRANSIENT
=YES options in the LIBNAME Instruction. The connection will be opened each time you use a table and closed at the end of using table.
Ask a Question
Discussion stats
  • 2 replies
  • 180 views
  • 0 likes
  • 1 in conversation