Your SAS programs, embedded in web apps and elsewhere

Failed to load Jquery in STP : the server responded with a status of 404 (Not Found)

Reply
New Contributor 13
New Contributor
Posts: 2

Failed to load Jquery in STP : the server responded with a status of 404 (Not Found)

Hi All,

 

Thank you all in advance.

I am trying to use Jquery and other javascripst in my Stored Process.

While calling the STP, the javascript files are not being linked to the page.

I have stored my .js files in below path

"Config\Lev1\Web\WebServer\htdocs" .

 

I am able to resolve below url :-

"http://sasserver.com/jquery.min.js"

 

Following is the way i am linking .js file to my STP

<script type="text/javascript" src="jquery.min.js"></script>

 

But while executing the STP, the files are not being linked with the page.

I have attached the screenshot, please share the solution.

 

 


Untitled.jpg
Contributor
Posts: 39

Re: Failed to load Jquery in STP : the server responded with a status of 404 (Not Found)

Hello, 

 

Welcome to the communities. 

 

I might be wrong, but you need a slash infront of your jquery reference. <script type="text/javascript" src="/jquery.min.js"></script>

Otherwise you can reference jQuery with absolute reference so it would be <script type="text/javascript" src="http://sasserver.com/jquery.min.js"></script>

 

Regards,

Vasilij

=======================================
For more information about {An}alytium, visit https://www.analytium.co.uk
Ask a Question
Discussion stats
  • 1 reply
  • 188 views
  • 0 likes
  • 2 in conversation