Your SAS programs, embedded in web apps and elsewhere

ActiveX Graph display from stored process

Reply
N/A
Posts: 0

ActiveX Graph display from stored process

Hi, I have a question about dynamic graph with stored process.

If we use WRS to create any graph, user can edit and select any type of graph they want, pie, bar, etc. If we use EG to create any graph, user can change the chart type from right click.
In my stored process, I use the option "device = gif" to display the graph with coding, it looks like fixed.
How to do to make the chart also dynamiclly as ActiveX format one in Enterprise Guide? Easy to transform from pie to bar, only depends on user's requirement.
SAS Super FREQ
Posts: 304

Re: ActiveX Graph display from stored process

Posted in reply to deleted_user
Try:

[pre]goptions device=activex;[/pre]

Vince DelGobbo
SAS R&D
N/A
Posts: 0

Re: ActiveX Graph display from stored process

Posted in reply to Vince_SAS
Hi,Vince,
this device = activex option is ok when I open it in SASStoredProcess, but if using WRS as the tool to open, there are some errors. Is it the problem the SAS version here 9.1.3 and WRS 3.1, not support this function?
And if using PROC REPORT in STP and open from WRS, the color,align, everything of column (define as ACROSS) could not be controled by the "Style statement". All these problem occured caused of the low version of SAS? Is there any solution for 9.1.3?
Thanks
SAS Super FREQ
Posts: 8,866

Re: ActiveX Graph display from stored process

Posted in reply to deleted_user
Hi:
One thing I noticed, when teaching the 9.1.3 stored process course is that some outputs -are- generated using a different style when accessing the stored process from within Web Report Studio. WRS wants the SP output results to be generated as SASReport XML and sometimes WRS doesn't use the CSS that might otherwise be respected by EG, for example.

The fact that WRS uses SASReport XML for the report format might also have something to do with your image issues. (But this is something you need to check with Tech Support). It is possible that your ACTIVEX controls are not compatible with the SASReport XML or just that your ACTIVEX controls are not loaded where they need to be loaded. Graphics in WRS (when you design a report from the WRS interface -- not via SP) are generated using Java technology.

I did not think interactive graphs could be returned from SPs to WRS -- I have always used goptions device=actximg or device=javaimg when creating SP results for WRS. Someone who's got more WRS experience may need to comment on this....or you could check this with Tech Support, too.

cynthia
N/A
Posts: 0

Re: ActiveX Graph display from stored process

Posted in reply to Cynthia_sas
Hi, Cynthia,
thank you so much for your explanation.

Fairy Message was edited by: mango
N/A
Posts: 0

Re: ActiveX Graph display from stored process

Posted in reply to Cynthia_sas
sorry for duplicated message Message was edited by: mango
N/A
Posts: 0

Re: ActiveX Graph display from stored process

Posted in reply to Cynthia_sas
sorry for duplicated message Message was edited by: mango
Ask a Question
Discussion stats
  • 6 replies
  • 305 views
  • 0 likes
  • 3 in conversation