Programming the statistical procedures from SAS

Proc Pareto vaxis not working

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 16
Accepted Solution

Proc Pareto vaxis not working

[ Edited ]

I am creating a weighted Pareto chart using Proc Pareto with the vertical axis scale=weight.  I've tried limiting the values on the vertical axis using vaxis but I keep getting an error that says "The FREQAXIS= list does not cover the range of the bars."  Looking at both my data and the values given if I include barlabel = value, my largest value is around 200K and I'm putting my largest vaxis value at 500K, so I don't understand why I'm getting this error.

 

Would someone be able to explain to me?  Thanks!

 

 


Accepted Solutions
Solution
‎02-27-2018 08:20 AM
SAS Employee
Posts: 10

Re: Proc Pareto vaxis not working

Posted in reply to railfan1975

The problem here involves the scaling of the primary vertical axis, which measures the bars, and the secondary vertical axis, which measures the cumulative percent curve.  By default. the leftmost point on the curve is attached to the top of the leftmost bar.  The log message here is misleading.  The real problem is that if you limit the primary axis range then the there is not enough vertical space to line up the axes so that the curve is anchored at the top of that bar.

 

There are at least two ways to get around this.  If you don't care about having the cumulative percent curve on your chart, you can specify the NOCURVE option.  Otherwise, you can use the AXISFACTOR= option to specify the ratio of the primary axis length to the height of the tallest bar.  In fact, if you're using the VAXIS= option to try to make the bars taller, you can use the AXISFACTOR= option instead.

View solution in original post


All Replies
Solution
‎02-27-2018 08:20 AM
SAS Employee
Posts: 10

Re: Proc Pareto vaxis not working

Posted in reply to railfan1975

The problem here involves the scaling of the primary vertical axis, which measures the bars, and the secondary vertical axis, which measures the cumulative percent curve.  By default. the leftmost point on the curve is attached to the top of the leftmost bar.  The log message here is misleading.  The real problem is that if you limit the primary axis range then the there is not enough vertical space to line up the axes so that the curve is anchored at the top of that bar.

 

There are at least two ways to get around this.  If you don't care about having the cumulative percent curve on your chart, you can specify the NOCURVE option.  Otherwise, you can use the AXISFACTOR= option to specify the ratio of the primary axis length to the height of the tallest bar.  In fact, if you're using the VAXIS= option to try to make the bars taller, you can use the AXISFACTOR= option instead.

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 1 reply
  • 141 views
  • 2 likes
  • 2 in conversation