Programming the statistical procedures from SAS

NLMIXED_Insufficient memory

Reply
Occasional Contributor
Posts: 5

NLMIXED_Insufficient memory

Dear all,

      I am now using proc nlmixed to estimate a GLMM model. But the programme stopped because of the insufficient memory. My data set is not very large, which contains

less than 1500 observations and 20 variables. I specified five random effects for different groups. Could you tell me how to fix this problem.

      I have tried to reset the memory size for SAS, but it failed. I don't know how to do that. It seems that I can not just submit "options memsize=-0m;" directly.

      Thanks.

Best regards

Respected Advisor
Posts: 2,655

Re: NLMIXED_Insufficient memory

I don't think the memory problem is due to the size of the dataset, but due to the complexity of the model.  Can you justify the inclusion of all variables and random effects on a subject matter basis?  Can some be combined or eliminated based on prior knowledge?  Peeling the model down to something much simpler and then adding IV's back in may be the only solution to this.

Steve Denham

Trusted Advisor
Posts: 1,036

Re: NLMIXED_Insufficient memory

Alternately, here's some advice on increasing your memory, in case that helps. Memory is allocated at the start of your SAS session, so you can't increase it during the session. You have to increase it before SAS starts.

First, make sure you know which memory options need to be increased. Second, check what they are currently (you can do this by running PROC OPTIONS).

Next, set up a new shortcut to SAS. Take the startup line out of your exisiting SAS program start icon, it should look something like this:

"C:\Program Files\SASHome\SASFoundation\9.3\sas.exe" -CONFIG "C:\Program Files\SASHome\SASFoundation\9.3\nls\en\sasv9.cfg"

Add your new memory option(s), so it looks something like this:

"C:\Program Files\SASHome\SASFoundation\9.3\sas.exe" -memsize 6G -CONFIG "C:\Program Files\SASHome\SASFoundation\9.3\nls\en\sasv9.cfg"

Start SAS using your new shortcut, and check what SAS is using for memory using PROC OPTIONS. It should reflect your new value.

Tom

Respected Advisor
Posts: 2,655

Re: NLMIXED_Insufficient memory

Hi Tom,

I tried this under Windows 7 64 bit.  On restart, I still only had 2 GB memory.  Any possibilities?  Am I going to have to edit the config file as well?

Thanks,

Steve Denham

Ask a Question
Discussion stats
  • 3 replies
  • 171 views
  • 0 likes
  • 3 in conversation