Help using Base SAS procedures

setting the sas font size in File/PrintSetup

Accepted Solution Solved
Reply
Contributor
Posts: 44
Accepted Solution

setting the sas font size in File/PrintSetup

I’m having a problem with printing from the output window. I’ve set the SAS font to 8, and these settings have been saved. However, when I open up SAS, and proc print something to the SAS Output window, it uses the original SAS font of 10. Each time I open SAS, I have to click on File/Print Setup/OK to get it to initialise itself to 8. I don’t need to go into the font size to set it to 8, because it remembers the setting – it just doesn’t apply it. How can I fix this? It’s very frustrating.


Accepted Solutions
Solution
‎10-05-2011 09:06 AM
Contributor
Posts: 44

setting the sas font size in File/PrintSetup

No wait - this is what I used!

options sysprintfont=("SAS Monospace" 8);

View solution in original post


All Replies
PROC Star
Posts: 7,356

setting the sas font size in File/PrintSetup

Under your preferences do you have "save settings on exit" checked off?

Contributor
Posts: 44

setting the sas font size in File/PrintSetup

yes, this is not the problem.

PROC Star
Posts: 7,356

setting the sas font size in File/PrintSetup

Was worth a try!  Next, have you tried setting it in your config file?  Take a look at: http://support.sas.com/documentation/cdl/en/lrdict/64316/HTML/default/viewer.htm#lr-sysop-sysprintfo...

Contributor
Posts: 44

setting the sas font size in File/PrintSetup

This worked - thank you! I put the following line into my autoexec.sas file:

options sysprintfont=("SAS Monospacetimes" 8);

Solution
‎10-05-2011 09:06 AM
Contributor
Posts: 44

setting the sas font size in File/PrintSetup

No wait - this is what I used!

options sysprintfont=("SAS Monospace" 8);

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 5 replies
  • 120 views
  • 3 likes
  • 2 in conversation