Help using Base SAS procedures

prog reg

Reply
New Contributor
Posts: 4

prog reg

i want to ask why my output of standard error is zero. here my command that i used

data MP02;

input N LAI SPAD HEIGHT DIAMETER BLUE GREEN RED NIR;

cards;

  1. 2.22      1.99 78.27      5.93      2.47 8.12      11.99     8.61 53.29
  2. 2.35      2.07 65.30      5.67      2.37 5.11      8.84      4.98 65.95
  3. 3.39      2.91 67.77      4.23      2.50 6.82      10.81     7.32 52.35
  4. 2.46      2.85 76.43      4.97      2.29 7.00      10.53     7.32 54.81
  5. 2.37      1.85 74.17      5.81      2.50 5.01      8.13      4.81 65.08
  6. 2.27      2.22 61.20      5.29      2.54 9.29      16.34     11.74 55.12
  7. 2.45      1.95 71.30      4.12      2.35 4.87      8.07      5.13 54.27
  8. 2.16      3.30 72.33      5.05      2.30 5.55      8.75 5.50      64.41
  9. 2.52      2.07 69.53      3.99      2.46 5.91      9.46      6.17 54.29

;

proc reg;

FORWARDSELECT:model N=  LAI SPAD HEIGHT DIAMETER BLUE GREEN RED NIR/SELECTION=FORWARD;

proc reg;

MAXR:model N= LAI SPAD HEIGHT DIAMETER BLUE GREEN RED NIR/SELECTION=MAXR;

proc reg;

MINR:model N= LAI SPAD HEIGHT DIAMETER BLUE GREEN RED NIR/SELECTION=MINR;

proc reg;

RSQUARE:model N= LAI SPAD HEIGHT DIAMETER BLUE GREEN RED NIR/SELECTION=RSQUARE;

proc reg;

ADJRSQ:model N= LAI SPAD HEIGHT BLUE GREEN RED NIR/SELECTION=ADJRSQ;

PROC PLOT; PLOT N*LAI N*SPAD N*HEIGHT N*DIAMETER N*BLUE N*GREEN N*RED N*NIR;

run;


is there anyone that can suggest what i should do?

Super User
Posts: 19,869

Re: prog reg

You have 9 observations and 8 variables in your actual data?

New Contributor
Posts: 4

Re: prog reg

i averaged according rep

i have three trt, three rep.. in each rep i take 8 plants and averaged for each data

Super User
Posts: 19,869

Re: prog reg

Ok...I think you should use a different analysis method if you have replicated measures, but that isn't the question you asked.

That being said, its your full model - where you have all 8 variables included- that is causing the issues. Given the DF=8 its not surprising. A intro stats text can probably explain it better, I'm rusty with the exact calculations.

proc reg data=mp02;

FULL:model N= LAI SPAD HEIGHT DIAMETER BLUE GREEN RED NIR;

run;

New Contributor
Posts: 4

Re: prog reg

the standard error still 0. is the problems is due to my data? how i can do the regression in correct way?

Super User
Posts: 19,869

Re: prog reg

You don't have enough data to generate standard errors.

I don't know what your actual data looks like so hard to say. Start a new thread with sample data if you'd like. Best to post these types of question in the Statistical Forum as well

New Contributor
Posts: 4

Re: prog reg

thanks reeza

Ask a Question
Discussion stats
  • 6 replies
  • 279 views
  • 3 likes
  • 2 in conversation