Help using Base SAS procedures

proc tabulate incorrect column percentages

Accepted Solution Solved
Reply
New Contributor
Posts: 3
Accepted Solution

proc tabulate incorrect column percentages

I am using proc tabulate to create a table like the one below.

 

percenttotal.PNG

 

It is intended to count the number of observations for each hospital location by year. Additionally, I would like to generate column percentages for each year's observations. 

 

I was able to create my desired layout, but my column percentage totals are coming out to 0%. They should be 100%. I can't seem to figure out what has happened with my nesting to cause this error. Any assistance would be greatly appreciated!

 

 

This is the code that I am using:

 

proc tabulate data=mydata ;
            CLASS location specdateYR/ PRELOADFMT order=data;
            CLASSLEV location specdateYR/ S=[background=bigb foreground=white];
            TABLE location = ' ' (ALL = {label='Total' S=[background=bigb foreground=white]}),
                         (specdateYR = ' ' (All= {label='Total' S=[background=bigb foreground=white]})) 
                         *((N= {label='N Events' S=[background=bigb foreground=white]}) 
                           ((colpctn= {label='% Events' S=[background=bigb foreground=white]})*f=pctfmt.)) 
                           /misstext='0' BOX=[label='Events By Year and Location*' S=[background=bigb foreground=white]];
run;

 

 


Accepted Solutions
Solution
3 weeks ago
Super User
Posts: 13,583

Re: proc tabulate incorrect column percentages

Posted in reply to sasuser34

Show the definitions of your PCTFMT. Likely you didn't allocate the correct options to show 100.00%.

View solution in original post


All Replies
Super User
Posts: 23,771

Re: proc tabulate incorrect column percentages

Posted in reply to sasuser34

Remove the format and are they still 0?

Solution
3 weeks ago
Super User
Posts: 13,583

Re: proc tabulate incorrect column percentages

Posted in reply to sasuser34

Show the definitions of your PCTFMT. Likely you didn't allocate the correct options to show 100.00%.

New Contributor
Posts: 3

Re: proc tabulate incorrect column percentages

 

This is the format I was using. 

 

proc format;
picture pctfmt (round) other='09.99%';
run;

 

I realized that my format did not allow for 3 digits. I changed the format to 

 

proc format;
picture pctfmt (round) other='009.99%';
run;

 

which corrected the issue. 

 

Thank you for pointing me in the right direction!

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 124 views
  • 0 likes
  • 3 in conversation