Help using Base SAS procedures

format

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 5
Accepted Solution

format

Hello everyone,

I am having an issue with a format. In a dataset in one system, say system A, a format named product is used. I need to use the same format & dataset in another system, say B. So how can I know how the format in system A has been defined so that I can use this in system B.

Please help me, I am having this issue for a long time, but cannot find a solution.


Accepted Solutions
Solution
‎05-03-2013 10:57 PM
Super User
Posts: 9,662

Re: format

first use

proc format cntlout=x

make a dataset named X .

transfer X into B system.

then run

proc format cntlin=x

Ksharp

View solution in original post


All Replies
Super Contributor
Posts: 543

Re: format

Hi.

Can you try this?

*---  enter name of format  -----*;

%let format = product;*possibly $product

proc format library = work.formats fmtlib;

select &format.;

run;

quit;

Let me know.

Trusted Advisor
Posts: 1,128

Re: format

Hi,

You can also use proc contents procedure to check the type of format used in dataset A. Proc contents procedure will display the attributes, engine, variables(length,type,format,label etc.,), and on which variable the dataset is sorted.

Here is the syntax

Proc contents data=A;

run;

if there are no formats used for the variables it will not display anything.

Hope this helps you.

Thanks,

Jagadish

Thanks,
Jag
Solution
‎05-03-2013 10:57 PM
Super User
Posts: 9,662

Re: format

first use

proc format cntlout=x

make a dataset named X .

transfer X into B system.

then run

proc format cntlin=x

Ksharp

Super User
Super User
Posts: 6,495

Re: format

The other issue you might need to check is the FMTSEARCH option so that you know where the format is stored.

Valued Guide
Posts: 2,174

Re: format

Tom,

The catalog holding each user format  is defined in SASHELP.VFORMAT

PeterC

(I think Ksharp has the correct answer)

Occasional Contributor
Posts: 5

Re: format

Can you please help me in giving below information?

I get mail saying that "you have not set a status update". Where to set the update?

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 6 replies
  • 343 views
  • 6 likes
  • 6 in conversation