Help using Base SAS procedures

error message: user does not have appropriate authorization level for library WORK

Reply
New Contributor
Posts: 2

error message: user does not have appropriate authorization level for library WORK

Dear all,

When I run a macro, I often get the error message 'user does not have appropriate authorization level for library WORK'.

Does anyone has had a similar problem and knows how to solve this?

Many thanks,

Eva

Trusted Advisor
Posts: 2,116

error message: user does not have appropriate authorization level for library WORK

not the usual.  You probably need to provide the log to show the error in context.

New Contributor
Posts: 2

error message: user does not have appropriate authorization level for library WORK

Thanks for you response but the log is not very enlightening. It simply states the error message I wrote and consequently states problems renaming datasets in the work library, which SAS cannot get access too so it places that file in temp...

Problem is that it doesn't happen allways but once in a while (and at the moment, I cannot get an error so no log to attach).

New Contributor
Posts: 3

error message: user does not have appropriate authorization level for library WORK

You need to modify the policies in SASWork folder.this depend in your setup..

Trusted Advisor
Posts: 1,932

Re: error message: user does not have appropriate authorization level for library WORK

Now I am having the same problem. Yes, I have checked, I have write permission to the appropriate WORK folder.

If I run the same program and use a server location as my WORK folder, the problem goes away. But this is not a good solution to constantly be writing temporary files across the network to a server location.

Has anyone found a solution to this problem?

Trusted Advisor
Posts: 1,932

Re: error message: user does not have appropriate authorization level for library WORK

Posted in reply to PaigeMiller

Okay, browsing the web using that new-fangled Google thing, I found the following solution which seems to have fixed the problem

http://support.sas.com/kb/40/459.html

Ask a Question
Discussion stats
  • 5 replies
  • 2857 views
  • 1 like
  • 4 in conversation