Help using Base SAS procedures

#byval(variable) doesn't get resolved

Reply
Contributor
Posts: 39

#byval(variable) doesn't get resolved

Hi Everyone!

Thank you for looking into my topic

The other day I ran into a problem generating reports using proc print and proc gplot. I use the #byval(var) function to create the titles for the box plot for each by Group. Except for the first page, the function gets resolved on all pages. The first page just says:

#byval (monat) / #byval(jahr)

I researched the problem and it has been suggested that I use "options nobyline" which I already do.

Code's attached. Thanks in advance!

Phil

Attachment
SAS Super FREQ
Posts: 8,869

Re: #byval(variable) doesn't get resolved

Posted in reply to PhilfromGermany

Hi:

  It seems to me that you are experiencing something like this 7456 - #BYVAL used in a TITLE statement in conjunction with PROC PRINT output displaysincorrect valu... only your behavior is with a different procedure and the first title is missing instead of the last title being missing. Because there is more than one Tech Support note on issues with #BYVAL, I would suggest that you open a track with Tech Support on this. You might have discovered a new twist of this problem and Tech Support are the only ones who can involve the developers if they need to.

cynthia

Contributor
Posts: 39

Re: #byval(variable) doesn't get resolved

Posted in reply to Cynthia_sas

Hi Cynthia, thank you for your response. I actually read that note earlier und figured it would have to somehow apply to the problem I'm encountering, except the first and not the last title is missing in my report (as you mentioned in your post).

Though opening a track is probably the right call, I just ended up using the byline statement instead.

Thanks!

Ask a Question
Discussion stats
  • 2 replies
  • 241 views
  • 3 likes
  • 2 in conversation