Help using Base SAS procedures

SAS job not failed in LSF @ Platform Process Manager

Reply
Occasional Contributor
Posts: 9

SAS job not failed in LSF @ Platform Process Manager

Hi,

I had schedule a SAS job using LSF @ Platform Process Manager.
Then, i trigger the job in LSF manually. The job end up successful with blue color.
Normally, if the job failed, it will turn to red color. Once the job completed, it generated log file. When i open the log file, i found error messages. Normally, if any job end up successful, no error log can be found in log file. So, may i know how to solve this problem?

Regards,
senico
SAS Super FREQ
Posts: 8,743

Re: SAS job not failed in LSF @ Platform Process Manager

Hi:
Each company and site will have differing configurations for the Enterprise Intelligence Platform. When you are using LSF on the Platform to schedule jobs, the log messages that get written probably need to be examined in more detail than can be addressed in the forum.

Your best bet for help with LSF questions is to open a track with Tech Support. They can look at your original job, look at your log, ask you configuration questions if necessary and work with your Administrator to resolve any issues that they identify.

To send a question to Tech Support, go to http://support.sas.com/ and in the left-hand navigation pane, click on the link entitled "Submit a Problem". Alternately, you can go directly to the Tech Support Problem Form here:
http://support.sas.com/ctx/supportform/createForm

cynthia
Occasional Contributor
Posts: 9

Re: SAS job not failed in LSF @ Platform Process Manager

Hi Cynthia,

Thanks for your feedback. I know that the best solution is to log this issue to SAS Tech Support. But, I just want to share my problem with other SAS user/expert in this forum. Maybe somebody or someone in this forum had face this problem before. I still hoping to get other solution from other expert from this forum.

Regards,
senico
SAS Super FREQ
Posts: 8,743

Re: SAS job not failed in LSF @ Platform Process Manager

Hi:
If you hope to find platform people, this may not be the correct forum. Since the LSF is part of the Enterprise Intelligence Platform, you might consider posting this in the Web Report Studio forum -- where there are more folks with Platform experience.

However, I would be remiss if I failed to point out that "The Forums should not be used in place of Technical Support for software issues that require SAS action." (Note at the bottom of every forum page.)

Because of the complexity involved in configuring the Platform and LSF; and because every site has a slightly different configuration, I still believe that you would be better served by contacting Tech Support. Usually, someone needs to look at your LSF log and the code that ran, as well -- which will be easier with Tech Support -- since you can't use attachments with Forum postings and you may not want your company information about jobs, names and servers posted publicly to the Forum.

cynthia
Super Contributor
Posts: 356

Re: SAS job not failed in LSF @ Platform Process Manager

Hi Cynthia

(Sorry to Hijack the thread)

Or there could be another forum created for SAS Platform Administration, as there seems to be a bit of a hole around this.

I know I would find it useful, as that is my primary role, rather than using the tools.

My two Cents.


Barry
Super Contributor
Posts: 356

Re: SAS job not failed in LSF @ Platform Process Manager

Hi Senico.

One thing to look at, is does your code change the return codes of sysrc, _error_ etc. (Can 't remember all of them).

Cheers

Barry
Ask a Question
Discussion stats
  • 5 replies
  • 216 views
  • 0 likes
  • 3 in conversation