Help using Base SAS procedures

Proc arima, no significant white noise at any lag after differencing

Reply
Contributor
Posts: 39

Proc arima, no significant white noise at any lag after differencing

Hi

I am using proc arima in sas for the first time, and I ran identify statement with my original variable and time, I found that there is significant auto correlation each lag(through following table)

First model also had non-stationarity  using Dickey Fuller Unit Root Tests, which is removed using differencing in the second step.

Autocorrelation Check for White Noise

To Lag    Chi-Square   DF   Pr > ChiSq   Autocorrelations

6         183.77       6    <.0001     0.793 0.660 0.545 0.494 0.468 0.418

12        229.03       12   <.0001     0.379 0.316 0.284 0.248 0.203 0.175

18        233.63       18   <.0001     0.115 0.116 0.119 0.040 0.010 -0.029

So I used differencing, and got following table for autocorrelation,

Autocorrelation Check for White Noise

To Lag Chi-Square DF  Pr > ChiSq Autocorrelations

6          6.15           6   0.4069    -0.168 -0.055 -0.162 -0.065 0.071 -0.034

12        7.97          12   0.7876     0.061 -0.078 0.010 0.037 -0.043 0.073

18       16.03         18   0.5903    -0.142 -0.009 0.192 -0.114 0.012 -0.075

I am confused that since now their is no autocorrelation in the white noise component, Should I model the difference using ordinary least square regression.

I actually tried OLS Regression too on difference, but it seems terrible. Pls suggest what can I do.

Sorry If you find me doing something funny.

Thanks

Ask a Question
Discussion stats
  • 0 replies
  • 156 views
  • 0 likes
  • 1 in conversation