Help using Base SAS procedures

Prevent "Results" tab from activating after every activity

Reply
Contributor
Posts: 38

Prevent "Results" tab from activating after every activity

Hi everyone. I'd like to know if there is a way to keep SAS from opening the "Results" tab of the docked area that contains both Results and Explorer. The reason being is I tend to be working in Explorer in a certain folder, and when I do something like made a table I normally like to open it from there.

As it is, SAS switches that window from Explorer to Results, even if there is no result (e.g. I just ran a proc import and a proc sort and there is no result, yet that docked window is switched from Explorer to Results). I then have to switch back to Explorer, then look at the table. I know it's a minor thing, but it's annoying none the less.

I tried Googling, and found what looked like a promising option (to turn off "View results as they are generated" in options), but that doesn't work. I also tried closing the results window, but it re-generates itself after each action.

Any help is appreciated, thanks.

Frequent Contributor
Posts: 117

Re: Prevent "Results" tab from activating after every activity

Use this in your code:

ODS NORESULTS

or

ODS RESULTS OFF


You can also go to Tools => Options => Preferences. On the Results tab, disable the option entitled "View results as they are generated"

Contributor
Posts: 38

Re: Prevent "Results" tab from activating after every activity

Hi vomer, in my original message, I stated that I tried the "View results as they are generated" option and it didn't do anything. I just tried your other suggestions, they did not help either. Any other ideas?

Frequent Contributor
Posts: 117

Re: Prevent "Results" tab from activating after every activity

Hmm strange, are you using it as follows:

ods noresults;

OR


ods results off;

Might also be a version incompatibility:

31789 - ODS output automatically opens in the Results Viewer window even when specifying ODS NORESUL...

Contributor
Posts: 38

Re: Prevent "Results" tab from activating after every activity

I tried it both ways. Does not change anything, explorer window gets switched away to results window. Even when I've closed the result window with the red X, it comes to life (and focus) after every sas process.

Super User
Posts: 17,828

Re: Prevent "Results" tab from activating after every activity

ods select none;

That works for me, not sure its a very good method though, make sure to set it back to ods select all; afterwards.

ods noresults doesn't work either (SAS 9.2 TS2M3)

Contributor
Posts: 38

Re: Prevent "Results" tab from activating after every activity

Hi Reeza, just tried it and it didn't work. I am using the same sas version 9.2 TS 2M3, on Windows 7.

SAS Super FREQ
Posts: 8,743

Re: Prevent "Results" tab from activating after every activity

Hi:

  Try using the Tools--> Options--> Preferences window as shown in the attached screenshot.

cynthia

Contributor
Posts: 38

Re: Prevent "Results" tab from activating after every activity

Hi Cynthia. Thanks but I tried that first. It's un-checked, but it opens the result window after each proc.

SAS Super FREQ
Posts: 8,743

Re: Prevent "Results" tab from activating after every activity

Hi:

  Sorry, I didn't quite understand what you wanted because at first, it sounded like not having the Results Viewer window open automatically, but now, in re-reading your post, it seems that you want your  TAB focus to ALWAYS stay on or return to the Explorer tab after you run a program. Usually, I don't even notice that the focus switches to the Results tab after I run a program because usually, that's where I want to be (on the Results tab).

   I'm not sure whether there is a Display Manager command to bring focus to a docked TAB. This would be a question for SAS Tech Support or some deep diving into the Display Manager documentation.

cynthia

Ask a Question
Discussion stats
  • 9 replies
  • 247 views
  • 0 likes
  • 4 in conversation