Help using Base SAS procedures

PROC Datasets - Label option not working

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 5
Accepted Solution

PROC Datasets - Label option not working

[ Edited ]

I'm trying to change the label of a variable. But the option is not working. In the log it is showing modification is successful. But the label for the variable is still blank. 

 

When I use other options like rename, it is working fine and the variable name is being changed.

 

Following is the below code, where I'm facing the issue.

 

data cls2;
    	set sashelp.class;
    run;
    
    proc datasets;
    	modify cls2;
    		rename name = t;
    		label  t = 'test'
    			   sex = 'test2'
    			   ;
    			   
    quit;

 

Following is the log for the above code

 

log_proc_datasets_issue.PNG

 

The output is

 

output.PNG

 

Could you please help me, where I'm getting the code wrong

 

 


Accepted Solutions
Solution
‎09-11-2017 03:02 PM
Super User
Posts: 23,749

Re: PROC Datasets - Label option not working

Check your options, there's a label/nolabel option that could be set on your server.

 

http://support.sas.com/documentation/cdl/en/lesysoptsref/69799/HTML/default/viewer.htm#p02de158iswt9...

View solution in original post


All Replies
Super User
Posts: 23,749

Re: PROC Datasets - Label option not working

Post the output from the suggested code on SO.

Occasional Contributor
Posts: 5

Re: PROC Datasets - Label option not working

Hi Reeza,

 

I've updated the post with the output.

Super User
Posts: 23,749

Re: PROC Datasets - Label option not working

That's not the output from the code. 

 

Occasional Contributor
Posts: 5

Re: PROC Datasets - Label option not working

thats the cls2 dataset modified after the proc datasets procedure is run.

Super User
Posts: 23,749

Re: PROC Datasets - Label option not working

Ok then. The code has no issues, your log has no issues. 

You're doing something wrong and unless you post the full log from the code I *had* posted on SO we can't tell you anything else.

Notice that that's the same response you're getting on SO. 

 

Good Luck. 

 

 

Solution
‎09-11-2017 03:02 PM
Super User
Posts: 23,749

Re: PROC Datasets - Label option not working

Check your options, there's a label/nolabel option that could be set on your server.

 

http://support.sas.com/documentation/cdl/en/lesysoptsref/69799/HTML/default/viewer.htm#p02de158iswt9...

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 6 replies
  • 456 views
  • 0 likes
  • 2 in conversation