Help using Base SAS procedures

How to turn off the default start of Enterprise Guide?

Reply
Frequent Contributor
Posts: 100

How to turn off the default start of Enterprise Guide?

Greetings:
Each time I double-click on a saved SAS file, the Enterprise Guide kicks off, even though I've never used Enterprise Guide at all. I use Windows XP and the SAS version is 9.2. It is true that I could right click to select open with SAS 9.2 but I'm hoping for a way to set the default start option.
Thank you!
Valued Guide
Posts: 2,177

Re: How to turn off the default start of Enterprise Guide?

on a reasonably standard install of foundation SAS9.2, the start menu SAS group should include a sub-group named like SAS 9.2 utilities. That includes a SAS File Types application that enables you to set the default SAS behaviour.
Frequent Contributor
Posts: 100

Re: How to turn off the default start of Enterprise Guide?

Thank you! This worked for me. (More details for the next beginner with similar questions: SAS 9.2 License Renewal and Utilities -> Manage SAS File Types (here you can check/uncheck which files you want to open with either Enterprise guide or SAS 9.2. I unchecked .sas when SAS EG was highlighted.)
Trusted Advisor
Posts: 2,115

Re: How to turn off the default start of Enterprise Guide?

Another approach in XP, with more flexibility, is to go to My Computer
select tools
select folder options
select file types
select the extension you wish to change
select advanced
then you can connect any file type to any application.

For instance, I connect .log and .lst files to EMACS.

Doc Muhlbaier
Duke
Frequent Contributor
Posts: 100

Re: How to turn off the default start of Enterprise Guide?

Thank you! Followed the instruction, changed .sas files to open with SAS system for Windows. When I double clicked on a sas code file, it did kick off the SAS 9.2. However I also got a warning message about a catalog file does not exist. Next an error message telling me an error occured while attempting to initialize a SAS desktop object from class sashelp.sasdesk.catmodel. My file did not open. I must have missed something, half way there Smiley Happy.
Ask a Question
Discussion stats
  • 4 replies
  • 190 views
  • 0 likes
  • 3 in conversation