Help using Base SAS procedures

Greenplum extract contains Special Characters

Reply
Super Contributor
Posts: 326

Greenplum extract contains Special Characters

Hi,

I have a table in greenplum. Encoding is utf-8. Some fields have a dash "-". When I extract this to the sas workspace the dash gets converted to weird character. Current workaround is to extract then convert the dataset to latin1 encoding. I checked that encoding for sas is also utf-8.

Any other options available? Thanks!

Trusted Advisor
Posts: 3,212

Re: Greenplum extract contains Special Characters

Check the ODBC, SAS/ACCESS greenplum Greenplum client setting (odbdc.ini)

It is this client setting where the translation is done when data is going to SAS form Greenplum.  It is the point where connection SAS/Greenplum is done. There should ben an encoding option at the Greenplum settings.

http://www.emc.com/collateral/software/white-papers/h8240-sas-greenplum-wp.pdf is mentioning a document "Geenplum database .. Connectivity Tools for Unix" on the distribution media (cannot find that one)
 
The database (server) has his encoding of at least the rows. Sometimes limited to utf-16 (fixed) and that being translated to utf-8 (variable) Your database connection being setup as user defined in utf8.
Having SAS running in a utf-8 session you must use clients that are supporting that. Only Eguide is documented tot have that implemented.

Running SAS in utf-8 setting is also requiring looking well at your coding. Not all SAS Coding is correctly run. SAS(R) 9.3 National Language Support (NLS): Reference Guide (wlatin1 is not the same as latin1)

SAS(R) 9.3 National Language Support (NLS): Reference Guide avoid the I18N L0 and L1 type functions.

Having your SAS session run in utf-8 is can block you in connections needing a latin1 encoding. Sounds weird but not all sessions of SAS in different encodings can be connected.
http://support.sas.com/resources/papers/AddingAdditionalSASWorkspaceServerstoSupportMultipleEncoding... 

---->-- ja karman --<-----
Super User
Posts: 10,023

Re: Greenplum extract contains Special Characters

Announce an option to allow SAS import utf-8 file :

infile 'c:\temp\HTML_batch_file_sample.html' dsd dlm='<>' encoding=utf8;

Xia Keshan

Ask a Question
Discussion stats
  • 2 replies
  • 333 views
  • 0 likes
  • 3 in conversation