Help using Base SAS procedures

Getting an Email notification

Reply
New Contributor
Posts: 4

Getting an Email notification

I am using this simple code to get an email notification, but i get an error. Can some one please help me

filename notify email "xxxxx@yahoo.com" subject = "Job Completed";
data _null_;
file notify;
put "The reports have been created successfully."; run;

ERROR: Undetermined I/O failure.
NOTE: The SAS System stopped processing this step because of errors.
NOTE: DATA statement used (Total process time):
real time 0.00 seconds
cpu time 0.00 seconds
Super Contributor
Super Contributor
Posts: 3,174

Re: Getting an Email notification

What is your SAS OS platform? SAS version? Is SAS running locally on your machine or on a remote server system? Possibly there are individual ports that are unavailable to you to use, likely SMTP EMAIL (outgoing) port maybe? The code you have shared appears correct syntactically. You will want to use PROC OPTIONS to check your EMAILSYS and other EMAIL-related parameters.

Scott Barry
SBBWorks, Inc.
New Contributor
Posts: 4

Re: Getting an Email notification

SAS windows XP; sas 9.2 version, yes i am running on my single machine
Super Contributor
Super Contributor
Posts: 3,174

Re: Getting an Email notification

You may want to start out by reviewing the OPTIONS FILEMSGS; parameter - the Google advanced search argument below locates some SAS support website matches:

options filemsgs email error site:sas.com


Otherwise you may need to contact SAS support, if it appears unusual that you should (or should not) be able to generate outgoing EMAILs, based on the experience within your own office and network. It also may be worth contacting your network and mail admin team to inquire whether they think that it's feasible for you to being sending EMAILs out from a SAS environment.

Scott Barry
SBBWorks, Inc.
Trusted Advisor
Posts: 2,113

Re: Getting an Email notification

In addition to Scott's comments, check this thread
http://support.sas.com/forums/thread.jspa?threadID=5850

The EMAILSYS parameters are not automatically set. You have to specify the name of the SMTP gateway you are using.
Ask a Question
Discussion stats
  • 4 replies
  • 140 views
  • 0 likes
  • 3 in conversation