Help using Base SAS procedures

Error running model from SAS training course

Reply
Occasional Contributor
Posts: 9

Error running model from SAS training course

I am attempting to complete the Forecasting Using SAS Forecast Server Software course. At the very start of the training I am asked to run a model in base SAS, but I receive the following error

 

ERROR: The SAS High-Performance Forecasting product with which HPFSELECT is associated is either not licensed for your system
       or the product license has expired. Please contact your SAS installation representative.

 

Here is the result of running

proc setinit;

run;

in base SAS:

 

System birthday:   24JUL2017.
Operating System:   WX64_WKS.
Product expiration dates:
---Base SAS Software                                                                                    30JUN2018
---SAS/GRAPH                                                                                            30JUN2018
---SAS/ETS                                                                                              30JUN2018
---SAS/Secure 168-bit                                                                                   30JUN2018
---SAS/Secure Windows                                                                                   30JUN2018
---SAS Forecasting For Desktop                                                                          30JUN2018
---SAS Enterprise Guide                                                                                 30JUN2018
---SAS Workspace Server for Local Access                                                                30JUN2018
---High Performance Suite                                                                               30JUN2018
---SAS Add-in for Microsoft Excel

 

I don't really know much about SAS. I am guessing this HPFSELECT is pointing to the wrong thing. When I first installed SAS and other components, I didn't have Forecasting for Desktop but instead just plain old Forecast Studio, which I couldn't use. So I wonder if there is some setting that controls what product this HPFSELECT tries to use. I may also be completely wrong about this. The training course itself suggests Forecasting for Desktop is just fine for doing the training. Thanks for your consideration.

Super User
Posts: 19,845

Re: Error running model from SAS training course

Run the following to see what's installed. Setinit shows what's licensed, but not necessarily installed.

 

proc product_status;run;
Occasional Contributor
Posts: 9

Re: Error running model from SAS training course

thanks @Reeza. here is the result of that run:

 

For Base SAS Software ...
   Custom version information: 9.4_M4
   Image version information: 9.04.01M4P110916
For SAS/GRAPH ...
   Custom version information: 9.4_M4
For SAS/ETS ...
   Custom version information: 14.2
For High Performance Suite ...
   Custom version information: 2.2_M5

 

Super User
Posts: 19,845

Re: Error running model from SAS training course

I don't know enough about Forecast Suite but I don't see it in the list. I would contact tech support to help ensure you have everything set up properly, it's looking like you don't. And since they likely close early for the long weekend, I'd put my ticket in soon. 

Occasional Contributor
Posts: 9

Re: Error running model from SAS training course

@Reeza thanks anyways for taking a look. I didn't know there was a difference between setinit and product_status; the documentation on both is nearly identical.

Ask a Question
Discussion stats
  • 4 replies
  • 156 views
  • 0 likes
  • 2 in conversation