Help using Base SAS procedures

Erratic proc fedsql behaviour

Reply
New Contributor
Posts: 2

Erratic proc fedsql behaviour

Hi,

I am using SAS 9.4 and have been experimenting with PROC FEDSQL and have been experiencing some weird results as shown below in the log:

 

procfedsql.png

As you can see everytime I run it I get a different result (I manually checked the dataset and the rowcount does match the log so that part is consistent).  Changing the code back to using proc sql I get the expected row count every time it is run. 

 

Does anyone know why fedsql is giving random results?  The input datasets are static and have never changed.

 

Many thanks,

Reece

Super User
Posts: 5,256

Re: Erratic proc fedsql behaviour

If you think that you have a solid case for a sw problem, you should open a track to SAS tech support.
Data never sleeps
SAS Employee
Posts: 5

Re: Erratic proc fedsql behaviour

Hi Reece,

I will follow up on this. What data source is the LSPMB library accessing? Also what SAS 9.4 release and platform are you using?

 

Sylvia

New Contributor
Posts: 2

Re: Erratic proc fedsql behaviour

Hi Sylvia,

LSPMB is given by: LIBNAME LSPmb SPDE "/data/SPDE/M_B_PNCHPI" partsize=1028;

 

%PUT sys-ver = &sysvlong and OS = &SYSSCP &SYSSCPL; 

sys-ver = 9.04.01M3P062415 and OS = LIN X64 Linux

 

Many thanks,

Reece

 

SAS Employee
Posts: 5

Re: Erratic proc fedsql behaviour

Reece,

Set the ANSIMODE option in the PROC FEDSQL statement. That should resolve the discrepancy.

 

Sylvia 

Ask a Question
Discussion stats
  • 4 replies
  • 176 views
  • 0 likes
  • 3 in conversation