Statistical programming, matrix languages, and more

How to prevent the "note:xxxx" to be displayed in log window when IML is running?

Accepted Solution Solved
Reply
Contributor
Posts: 22
Accepted Solution

How to prevent the "note:xxxx" to be displayed in log window when IML is running?

When i use create statement to create a data set in a  do iteration in IML, the message"note: a data set xxx has one varialbe and xx " pops up repeatedly in log window , which slows down the computaion. How to prevent that happens?


Accepted Solutions
Solution
‎06-30-2017 03:49 PM
SAS Super FREQ
Posts: 3,898

Re: How to prevent the "note:xxxx" to be displayed in log window when IML is running?

Posted in reply to IanWakeling

All Replies
Regular Contributor
Posts: 159

Re: How to prevent the "note:xxxx" to be displayed in log window when IML is running?

Posted in reply to ShufeGuoding

You can add "options nonotes;" before you start IML and this will suppress all such notes.  However I would not have thought that printing notes to the log would slow down your program by much.  If you are trying to create lots of small data sets, then perhaps think about collecting results together into a few larger matrices, as there should be less I/O overhead writing out the larger data sets.

Solution
‎06-30-2017 03:49 PM
SAS Super FREQ
Posts: 3,898

Re: How to prevent the "note:xxxx" to be displayed in log window when IML is running?

Posted in reply to IanWakeling
🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 1156 views
  • 0 likes
  • 3 in conversation