Data visualization with SAS programming

title not show up in proc gchart

Reply
Occasional Contributor
Posts: 9

title not show up in proc gchart

Hi,

Does anyone try to run the sample code on http://support.sas.com/kb/26/105.html ? according to this article, the output should look like this:

 

SampleOutput.png

however when this sample code running on my SAS 9.4, the output looks like this:

RunningonMyMachineOutput.png

on which you can see, the title for each single chart is disappeared, and the big title was moved out from the first chart to the top of the whole picture.

 

How do i get the single chart title show up? I am utilizing this demo for a real report chart, and having the exactly same issue.

 

appreciate if anyone can help,

Fran

Grand Advisor
Posts: 16,334

Re: title not show up in proc gchart

Since that code is from SAS 9.1 HTML didn't exist as an output option then. 

Try switching to Listing. 

 

Also, check the GTITLE option setting. 

Occasional Contributor
Posts: 9

Re: title not show up in proc gchart

Hi Reeza,

thanks for your reply, i am still new to sas code. could you please elaborate a little bit more? are you saying the sample code was written based on SAS 9.1 version, and when running on 9.4 it should be altered? but how to? can you please get to the code level?

Thanks,

Fran

Occasional Contributor
Posts: 9

Re: title not show up in proc gchart

Hi Reeza,

just add one more thing: the title shows up in single slide dashboard though. sample: http://support.sas.com/kb/26/104.html

what would make the two different?

 

Thanks,

Frances

Grand Advisor
Posts: 16,334

Re: title not show up in proc gchart

Try the following. Not in front of a computer so can't comment otherwise. 

 

 

 

ODS html close;

ods listing;

 

rest of sas code goes here. 

Occasional Contributor
Posts: 9

Re: title not show up in proc gchart

Thanks Reeza, TS Martin helped me out, here is the solution for me: (this issue only exists when submitting code from EG)

 

from the dropdown options menu at the top of your Enterprise Guide windows, select:

 

TOOLS -> OPTIONS

 

On the left hand side under Results, click Graph.  Then on the right hand side, for Graph Format, set the value of the Graph Format option to PNG.  Once you do this, on the same screen, under "Options for PNG", enable the following 2 options:

 

Include titles inside the image

Include footnotes inside the image

 

Then click OK to return to EG

 

Thanks again,

Fran

 

Post a Question
Discussion Stats
  • 5 replies
  • 155 views
  • 0 likes
  • 2 in conversation