Data visualization with SAS programming

line plots with html links (problem with format of markers)

Reply
Contributor
Posts: 47

line plots with html links (problem with format of markers)

Hi all,

I've pretty much copied the code from Rob's codes:
http://robslink.com/SAS/democd23/scat.htm
http://robslink.com/SAS/democd23/scat_info.htm
and
http://robslink.com/SAS/democd23/overlib.htm
http://robslink.com/SAS/democd23/overlib_info.htm

anyway i have the htmlvar working and i can get the links to goto google and another page BUT, by running the code below I get a huge blue blob which covers the data points to click on and the data points are not linked by a line.

symbol i=join v=dot;
proc gplot data=test_mydata2;
format gross_combined_ratio percent.;
plot gross_combined_ratio*sasdate=measure/
html=htmlvar;
run;
quit;

Any workaround?
Thanks,
Sachin
SAS Employee
Posts: 963

Re: line plots with html links (problem with format of markers)

It's hard to tell, with the information given.

You might need to post the whole SAS job and/or some of your data.

Do you still get the blue blob if you leave out the javascript part (ie, just running the gplot)?
Contributor
Posts: 47

Re: line plots with html links (problem with format of markers)

Hi Rob,

It worked when I ran it the next day. Think the problem was because of the previous calculations not deleting the settings. Hopefully SAS addresses this issue rather than having to write extra code to do the same job (or maybe thats simply something you have to do; new to SAS so forgive me if what I said is not a database programmers thing to say.)

Thanks,
Sachin
SAS Employee
Posts: 963

Re: line plots with html links (problem with format of markers)

Not to worry - it's one of those "graph things" that takes a while to get used to ;-)

To avoid such problems (ie, unwanted affects of settings from a previous graph carrying-over and affecting my current graph), I almost always run my graphs in batch, cranking up a new SAS session for each graph, guaranteeing that all the graphics options/etc get reset.
Super Contributor
Posts: 291

Re: line plots with html links (problem with format of markers)

so you don't trust goptions reset=all????
SAS Employee
Posts: 963

Re: line plots with html links (problem with format of markers)

I trust it to reset what it resets... :-)

But it doesn't reset "everything", like starting a fresh SAS session does!
Post a Question
Discussion Stats
  • 5 replies
  • 126 views
  • 0 likes
  • 3 in conversation