Data visualization with SAS programming

WARNING: 'htmlblue' was compiled using a different version of SAS.

Reply
Contributor
Posts: 35

WARNING: 'htmlblue' was compiled using a different version of SAS.

[ Edited ]

I've just updated my Windows SAS environment from SAS 9.4M3 64-bit to SAS 9.4M4 64-bit and Enterprise Guide 7.13 HF2, and every time I ran a program I've started seeing 3 warning messages at the top of the SAS Log:

 

WARNING: 'def' was compiled using a different version of SAS. This might result in unexpected behavior.
WARNING: 'stat' was compiled using a different version of SAS. This might result in unexpected behavior.
WARNING: 'htmlblue' was compiled using a different version of SAS. This might result in unexpected behavior.

 

I don't like seeing error and warning messages in my SAS Log at any time. So I thought I'd help you, so you don't have to search any further, by providing this very easy fix, which is complicated to do in SAS, but easy in Windows Explorer:

  1. Open the My SAS Files folder in your My Documents folder, which is actually your SASUSER library.
  2. Delete the templat.sas7bitm file, which contains the def, stat and htmlblue style templates.

The warning messages should now have gone!  :-)

Trusted Advisor
Posts: 1,137

Re: WARNING: 'htmlblue' was compiled using a different version of SAS.

Thanks @hollandnumerics I just had the same experience, and the only page returned by google was your post.

 

Curious if there was any explanation from SAS about this.  Why would they write this these templates to the USER library?  Rather than simply delete this file, would there be a benefit to SAS posting the code for these templates so that users can recompile them?

SAS Super FREQ
Posts: 862

Re: WARNING: 'htmlblue' was compiled using a different version of SAS.

If these template are written to SASUSER, it means that a user tried to compile them themselves and were probably modified from the original version in SASHELP. Once the user compiles a template, they are responsibly for moving it forward to the next SAS version by recompiling it (or deleting it if you do not want it). The way you would move it forward is by "sourcing" the template and recompiling it with PROC TEMPLATE:

 

proc template;

source styles.mystyle;

run;

 

proc template;

<put source from the log here>

run;

 

Hope this helps!

Dan

Trusted Advisor
Posts: 1,137

Re: WARNING: 'htmlblue' was compiled using a different version of SAS.

Thanks @DanH_sas

 

That makes sense, but seems suspicious that @hollandnumerics and I got exactly the same warning message from an upgrade to 9.4M4 64 bit.  I do my best to avoid writing templates to SASUSER. I thought I was doing a "clean" install of 9.4 on a new PC.  But on reflection, it's conceivable that that my copy of My Documents\My SAS Files\9.4\templat.sas7bitm orginated from an earlier install on a different PC.  It's notable that everything in the directory has a mod date of today, except the moddate of templat.sas7bitm is 11/10/2013.

 

Then again, if the installer had somehow generated this file, I would think there would be more than two of us complaining. : )

 

--Q.

Post a Question
Discussion Stats
  • 3 replies
  • 170 views
  • 5 likes
  • 3 in conversation