Data visualization with SAS programming

SGE=ON Syntax Error

Reply
N/A
Posts: 1

SGE=ON Syntax Error

Greetings,

I am running SAS 9.2 TS Level 1M0 on a Windows 7 PC, and cannot use ODS LISTING SGE=ON when trying to run PROC SGPLOT. I get the following message in the log file:

ODS LISTING SGE=ON;
---
22
76
ERROR 22-322: Syntax error, expecting one of the following: ;, BODY, CLOSE, DATAPANEL, EXCLUDE, FILE, GPATH,
IMAGE_DPI, PACKAGE, SELECT, SHOW, STYLE.
ERROR 76-322: Syntax error, statement will be ignored.

PROC SGPLOT DATA = KMPLOT6;
SERIES X = AGE Y = W0_48;
SERIES X = AGE Y = W50_68;
SERIES X = AGE Y = W70_100;
RUN;
ODS LISTING SGE=OFF;

Any ideas as to why this might be happening?

Dave
SAS Super FREQ
Posts: 1,044

Re: SGE=ON Syntax Error

This option was introduced with SAS 9.2 (TS2M3). With TS2M0, you have to use the SGEDIT ON command in th command line. This has to be done with the Results Window in focus.

Now when you run a ods graphics task (SGPLOT or STAT procedure), editable SGE files will be created and listed in the Results window. You can turn SGEDIT OFF the same way.
SAS Super FREQ
Posts: 864

Re: SGE=ON Syntax Error

For 9.2 Level 1, you have to invoke the SGE output a different way. Highlight the RESULTS window, and type "sgedit on" in the command box. Typing "sgedit off" toggles the output off. After Level 1, the way you specified is the correct way to turn on SGE output.

Hope this helps,
Dan
Super Contributor
Super Contributor
Posts: 3,174

Re: SGE=ON Syntax Error

Are you licensed for SAS/Graph? Use PROC SETINIT to see what you have installed for your SAS system.

Scott Barry
SBBWorks, Inc.
Grand Advisor
Posts: 9,748

Re: SGE=ON Syntax Error

SETINIT shows what is licensed, not what is actually installed. Some organizations will not install portions of what is licensed for some users. So SETINIT is necessary but not sufficient criteria.


Message was edited by: ballardw
Post a Question
Discussion Stats
  • 4 replies
  • 228 views
  • 0 likes
  • 5 in conversation