Data visualization with SAS programming

PROC SGPLOT graphics horizontal axis Chinese does not display?

Reply
New Contributor
Posts: 3

PROC SGPLOT graphics horizontal axis Chinese does not display?

Dear sas experts: I come from china,first time to give a message.I have a question about graphics. the data as follow: adr v1 v2 v3 v4 中性粒细胞降低 7.5 50 32.5 2.5 发热 4.5 7.6 3.4 1 ............................... the adr column is chinese character.v1-v4 are percentage. the sas code for sas 9.4 M2: proc sgplot data=ae noborder noautolegend; vbarparm category=adr response=v /group=grade TRANSPARENCY=0 groupdisplay=stack discreteoffset=0.05 NAME='TR' DATASKIN=NONE fill GROUPORDER=ASCENDING; xaxis label = '不良反应' DISPLAY=ALL VALUEATTRS=(Family='Arial' Style=NORMAL color=black Size=9); yaxis label = 'Percentage of Patients' values = (0 to 100 by 10) minor MINORCOUNT=1 labelATTRS=(color=black Size=9); ; keylegend 'TR'/ title=" " location=inside position=TOPRIGHT across=1 down=2 noborder; run; run the code,then get... The horizontal axis Chinese value,eg :'中性粒细胞降低' is not displayed...I don't know Where is the problem? thanks for your answer.
New Contributor
Posts: 3

Re: PROC SGPLOT graphics X axis Chinese does not display?

I'm sorry! Dear sas experts: I come from china,first time to give a message.I have a question about graphics. the data as follow: adr v1 v2 v3 v4 中性粒细胞降低 7.5 50 32.5 2.5 发热 4.5 7.6 3.4 1 ............................... the adr column is chinese character.v1-v4 are percentage. the sas code for sas 9.4 M2: proc sgplot data=ae noborder noautolegend; vbarparm category=adr response=v /group=grade TRANSPARENCY=0 groupdisplay=stack discreteoffset=0.05 NAME='TR' DATASKIN=NONE fill GROUPORDER=ASCENDING; xaxis label = '不良反应' DISPLAY=ALL VALUEATTRS=(Family='Arial' Style=NORMAL color=black Size=9); yaxis label = 'Percentage of Patients' values = (0 to 100 by 10) minor MINORCOUNT=1 labelATTRS=(color=black Size=9); ; keylegend 'TR'/ title=" " location=inside position=TOPRIGHT across=1 down=2 noborder; run; run the code,then get... see attached PDF,The X axis Chinese value,eg :'中性粒细胞降低' is not displayed...I don't know Where is the problem? thanks for your answer.
SAS Super FREQ
Posts: 442

Re: PROC SGPLOT graphics X axis Chinese does not display?

https://support.sas.com/resources/papers/Multilingual_Computing_with_SAS_94.pdf

 

Perhaps this will help? I am not knowledgeable about enabling international characters, but you might need to change your LOCALE and ENCODING options or fonts.

Highlighted
New Contributor
Posts: 3

Re: PROC SGPLOT graphics X axis Chinese does not display?

Posted in reply to WarrenKuhfeld
Thanks very much.I will try to change LOCALE and ENCODING options,if ok, that's great.
Ask a Question
Discussion stats
  • 3 replies
  • 200 views
  • 0 likes
  • 2 in conversation