Data visualization with SAS programming

How to suppress the plot description in html drill down graph

Reply
Frequent Contributor
Frequent Contributor
Posts: 94

How to suppress the plot description in html drill down graph

I am using gplot to produce a drill down scatter plot (in a stored process). I want to suppress the default plot description that appears with the 'html=' option.

I have tried using noaltdesc option but that doesn't work.

I am using the 'alt=' option to display a tool tip for each dot on the graph.

The input dataset has a structure like this:

data outdata; 

  set indata;

    length DrillDown_link $400 ;

    DrillDown__link= ' target='||quote('_self')||' href='||  quote('http://mywebserver/do?_action=execute,nobanner&_program=mystoredprocess' ) ||' alt='||quote(compress(trim(Name)));

  run;

The plot code is similar to this:

goptions device=png noaltdesc; 


proc gplot data=outdata;                 

plot var1*var2 /

html= DrillDown_link

/*description='  '*/

/*description='Graph of mean absolute total difference on all seed scripts to date';*/

run;

quit;    

The code works fine in giving me the drill down and the alt as I want it. However it still shows the text 'target=' when mouse is hovered on the graph (please see the attached image). I have tried suppressing the description (by using noaltdesc) and also tried to give a blank description (description='  ') but have not been able to resolve it.

Is there a way to completely suppress the description?

Thanks.

Attachment
SAS Employee
Posts: 967

Re: How to suppress the plot description in html drill down graph

You should be able to suppress it by using the noaltdesc option, or des= option. I usually just give des= a value of two single-quotes, with no space between ...

proc gplot data=foo;

plot y*x / des='';

run;

If that doesn't work, I guess we'll have to get into more specifics, such as ...

Which device are you using? (hopefully png, and not activex/actximg or java/javaimg, which are the defaults for stored processes, I think)

Which version of SAS are you using? (hopefully something recent - I see an old defect which indicates a problem in this area, fixed in 9.2)

And could you post your stored process code (minus any bits that are proprietary) so we can see how you're coding everything?

(note that I don't have access to a stored process server at the moment, so I'm just going by memory)



Frequent Contributor
Frequent Contributor
Posts: 94

Re: How to suppress the plot description in html drill down graph

Thanks Robert.

I tried using noaltdesc option and des= with single as well double quotes - with and without spaces but it doesn't work. The best I could achieve was using single quotes wrapped inside double quotes - without any spaces (des="''"). It gives two single quotes in the output (please see the attached image).

It'd be tricky to post the stored process code - it's very lengthy.

I am using png device and EG 6.1.

Interestingly, I don't get this problem when I run the stored process on its own in a web browser. The problem arises only when the stored process is run in the Web Report Studio.

SASg1.png

SAS Employee
Posts: 967

Re: How to suppress the plot description in html drill down graph

Are you certain it's running as device=png?  By default stored processes running on a Unix server use device=javaimg by default, and PC servers use device=actximg by default (I think).

I think you have to do something like this in the stored process to override the default (but I'm very uncertain when it comes to setting it up from EG or WRS)...

%let _GOPT_DEVICE=png;

%let _ODSOPTIONS=gtitle gfootnote style=sasweb;

%stpbegin;

Ask a Question
Discussion stats
  • 3 replies
  • 465 views
  • 0 likes
  • 2 in conversation