Forecasting using SAS Forecast Server, SAS/ETS, and more

Proc Panel GMM - Artest problem

Reply
N/A
Posts: 1

Proc Panel GMM - Artest problem

Hi,

I'm using SAS Enterprise Guide 5.0 to estimate a dynamic panel model with GMM (Arellano Bond Model). I have an unbalanced panel dataset which consists of about 30000 individuals over 6 years. I'm using the following code:

proc panel data=data_base;

  id i t;

  clag y(1) / out=data_base_lag;

run;

proc panel data = data_base_lag;

    id i t;

    instruments depvar;

    model y = y_1 x_1 x_2 x_3 /gmm twostep maxband=4 robust artest=2;

run;

The output is providing the "Fit Statistics", "Sargan Test" and "Parameter Estimates". But the result of the test for autocorrelation in the residuals (ARTEST) is not been provided. The result for this test is the following table, filled with ".".

        

AR(m) test


Lag

Statistic

Pr > Statistic

1

.

.

2

.

.

3

.

.

Do you have any idea why is this happening?

Thanks,

Neto

N/A
Posts: 1

Re: Proc Panel GMM - Artest problem

Hi Neto,

I have the same problem in SAS. Please let me know if you had solution to figure it out or not?

Many thanks.

lemai

SAS Employee
Posts: 17

Re: Proc Panel GMM - Artest problem

Neto and Lemai,

In my experience, this most often arises from a singular regression that is encountered while calculating the test.  If Neto could email me some data that reproduces the problem at Bobby.Gutierrez@sas.com, I'll be glad to take a closer look and recommend a solution.

--Bobby

Occasional Learner
Posts: 1

Re: Proc Panel GMM - Artest problem

Hello, 

I am working on something similar and received the same problem. 

Anyone have an idea what it might be the reason?

 

Thanks

Ask a Question
Discussion stats
  • 3 replies
  • 1729 views
  • 0 likes
  • 4 in conversation