Desktop productivity for business analysts and programmers

"Statement is not valid..." when using SAS® Enterprise Guide and SAS/GRAPH®

Reply
Occasional Contributor
Posts: 5

"Statement is not valid..." when using SAS® Enterprise Guide and SAS/GRAPH®

I am using Enterprise Guide 4.22 with no license for SAS Graph. I found a hotfix to overcome my error for previous release 4.21 and 4.2. Those hotfixes (A20001wn and A32001wn) can not be used together with release 4.22.
http://support.sas.com/kb/35/771.html
Is there a solution (hotfix) available for EG 4.22 Message was edited by: HenkT
Super Contributor
Super Contributor
Posts: 3,174

Re: "Statement is not valid..." when using SAS® Enterprise Guide and SAS/GRAPH®

The condition you are receiving would be best served by contacting SAS support and opening a track on the support page.

Scott Barry
SBBWorks, Inc.
Community Manager
Posts: 2,884

Re: "Statement is not valid..." when using SAS® Enterprise Guide and SAS/GRAPH®

The same workaround should work with EG 4.22. Most EG customers have Stat and Graph (love those ODS graphics!), so it's not an issue that most will see.

But for those who don't, there is a configuration file setting that you can use that will prevent this GOPTIONS statement from being generated. Tech support can provide the details.

Chris
Occasional Contributor
Posts: 5

Re: "Statement is not valid..." when using SAS® Enterprise Guide and SAS/GRAPH®

I have received a solution in modifying the EG configuration file by TechSupport.
After this modification the error was gone.
Unfortunately STAT and GRAPH are not licensed which caused the error.

Thanks
Henk
Ask a Question
Discussion stats
  • 3 replies
  • 101 views
  • 0 likes
  • 3 in conversation