Desktop productivity for business analysts and programmers

"Object reference not set to an instance of an object" Ideas? Hints?

Accepted Solution Solved
Reply
Frequent Contributor
Posts: 100
Accepted Solution

"Object reference not set to an instance of an object" Ideas? Hints?

I've just installed SEG 7.12 (7.100.2.3350) (64 bit) on my laptop which is running Windows 7 Enterprise verson 6.1 (Build 7601, Svc Pack 1).  I'm frequently getting an error "Object reference not set to an instance of an object".  See also below.  This mainly happens when I delete something from my project.  For example, say I open a SAS dataset.  I just want to look something up and don't want it to be a part of my project.  When I delete it from my project, I get "Object reference not set to an instance of an object".

 

I've also noticed problems with things, apparently, not saving properly.  Unless I do a "Save As" and replace, some SAS program changes are gone when I close and then go back into a project.  Presumably, I unknowingly did something during set up.  I suppose I could de-install and re-install, but has anyone encountered anything like this?  And what did you do to resolve it?  Did you find any particular SAS documentation helpful?

 

Thanks,

 

Jim


SASEG71_Problem1.JPG


Accepted Solutions
Solution
‎10-17-2016 08:05 AM
SAS Super FREQ
Posts: 271

Re: "Object reference not set to an instance of an object" Ideas? Hints?

I'm fairly certain you are encountering this:

http://tsdsrv05.unx.sas.com:7777/iw/docs/sasnotes/fusion/57/979.html

 

It was fixed in 7.12 HF2, released today.  You should get notification in EG 7.12 the next time you start EG or if you click Help->Check for updates.  Or you can download and apply the traditional way from here:

http://ftp.sas.com/techsup/download/hotfix/HF2/Y39.html

View solution in original post


All Replies
Frequent Contributor
Posts: 100

Re: "Object reference not set to an instance of an object" Ideas? Hints?

[ Edited ]

Well, I haven't completely tested this yet, but I applied the hot fixes and upgrades for SEG 7.12, and... I've stopped getting the "Object reference not set to an instance of an object" errors that I was getting.  If so, best and most timely upgrade ever.  I should be able to confirm tomorrow.

 

Jim

Frequent Contributor
Posts: 100

Re: "Object reference not set to an instance of an object" Ideas? Hints?

Unfortunately, the problem hasn't gone away, at least not entirely.  I'm still getting "Object reference not set to an instance of an object" when I close SEG 7.1 after having worked on a project.  Everything else appears to be functional.  A minor nuisance at this point (unless I lose more work), but if anyone had a suggestion as to how to debug the problem, I would be most obliged.

 

Jim

Community Manager
Posts: 2,695

Re: "Object reference not set to an instance of an object" Ideas? Hints?

@jimbarbour I recommend working with tech support.  You'll want to turn on the Application Logging (in Tools->Options) and send the resulting log file -- be sure it represents an entire EG session (after you close the app and see the exception.)  I suspect EG is having trouble writing out your preferences that might have changed during the session, but only the app log can help diagnose.

Frequent Contributor
Posts: 100

Re: "Object reference not set to an instance of an object" Ideas? Hints?

@ChrisHemedinger, ah, of course, the log files.  

 

I suspect the problem arises from the fact that I had a prior version of SEG (4.3) on my machine in SASHome.  When I installed SEG 7.1, I noticed that the installation went into SASHome2.  I'm imagining that there is some dll that is not being accessed because it's in a different SAShome, although that's just a guess.  Your suspicion that EG is having trouble writing out preferences of some type may be well founded.  

 

Thanks, and I'll post an update here when I have further information (and hopfully report that I have a solution).

 

Jim

New Contributor
Posts: 2

Re: "Object reference not set to an instance of an object" Ideas? Hints?

@jimbarbour Have you resolved this yet? I have a user with the same issue when closing EG 7.11. Her error text is the same as yours. I suspected her issue was caused by using two different servers (Local and SASApp) in the same session, and bouncing back and forth between them repeatedly. If Tech Support has been able to resolve it, I'd love to know. Otherwise I'll have her generate some logs of her own to send in. Thanks.

Occasional Learner
Posts: 1

Re: "Object reference not set to an instance of an object" Ideas? Hints?

The message "Object not set to instance of Object" means that you are trying to use an object which has not been initialized. That is, you either set it to null, or you never set it to anything at all. The runtime throwing a NullReferenceException always means the same thing: you are trying to use a reference. The reference is not initialized (or it was initialized, but is no longer initialized).

 

Antonio

Frequent Contributor
Posts: 100

Re: "Object reference not set to an instance of an object" Ideas? Hints?

Sorry to take so long to reply.  I didn't see this when you posted it.  Just saw it now.

 

Yes, the issue was resolved, presumably by the latest fix released by SAS.

 

Jim

Solution
‎10-17-2016 08:05 AM
SAS Super FREQ
Posts: 271

Re: "Object reference not set to an instance of an object" Ideas? Hints?

I'm fairly certain you are encountering this:

http://tsdsrv05.unx.sas.com:7777/iw/docs/sasnotes/fusion/57/979.html

 

It was fixed in 7.12 HF2, released today.  You should get notification in EG 7.12 the next time you start EG or if you click Help->Check for updates.  Or you can download and apply the traditional way from here:

http://ftp.sas.com/techsup/download/hotfix/HF2/Y39.html

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 8 replies
  • 7757 views
  • 2 likes
  • 5 in conversation