Desktop productivity for business analysts and programmers

library not available to see for users

Accepted Solution Solved
Reply
Super Contributor
Super Contributor
Posts: 340
Accepted Solution

library not available to see for users

Admin is trying to create BASE library for user but its not getting available for users...

Library properties:

sas eg 4.1

engine=base

pre-assigned

path=share drive path on local machine

assign=sasmain

public/sas system services: authorization= RM/CIM/WM (indirect permission)

administrator authorization: everything (indirect permission)

object server parameters: metaautoinit

Thank you all...


Accepted Solutions
Solution
‎10-08-2013 03:08 PM
Super User
Posts: 3,235

Re: library not available to see for users

When defining SAS data libraries in SAS metadata where are two areas of security/permissions that need to work.

The first is the operating system security on the folder you are allocating. Try defining your library in a standard SAS code libname statement (I'm assuming your operating system is Windows): libname test "\\Myshare\Myfolder"; Does the statement run without error and does the new library appear in your EG server list after refreshing with the expected datasets in it? If yes then Windows permissions are working correctly. If not the Windows security/permissions on the folder need changing. This is normally handled via Windows AD user groups.

The second is the metadata security setup. Can the library name itself be seen in the EG server list but no tables under it or is the library name not showing at all? If it is not showing at all your metadata security is probably not set up correctly. Please confirm which of these is the case. 

View solution in original post


All Replies
Valued Guide
Posts: 3,208

Re: library not available to see for users

a/ do not forget to restart when server parameters have changed

b/ remember the app-server running on the serverside must be used to define the physical naming, not the one that is possible seen by the users/desktop.

A more easy approach could be the use of the user_mods autoexec file of app-server.  

With eguide 5 you are getting an autoexcec flow in Eguide that can be used by the user.

---->-- ja karman --<-----
Super Contributor
Super Contributor
Posts: 340

Re: library not available to see for users

we are still strugling make library avaialble to users from MC...

WHAT IS THE BEST WAY TO DEFINE "BASE" LIBRARY FROM MC FOR USERS TO STORE THE DATASET AND SHARE IT WITH OTHER USERS?

Thanks---

Solution
‎10-08-2013 03:08 PM
Super User
Posts: 3,235

Re: library not available to see for users

When defining SAS data libraries in SAS metadata where are two areas of security/permissions that need to work.

The first is the operating system security on the folder you are allocating. Try defining your library in a standard SAS code libname statement (I'm assuming your operating system is Windows): libname test "\\Myshare\Myfolder"; Does the statement run without error and does the new library appear in your EG server list after refreshing with the expected datasets in it? If yes then Windows permissions are working correctly. If not the Windows security/permissions on the folder need changing. This is normally handled via Windows AD user groups.

The second is the metadata security setup. Can the library name itself be seen in the EG server list but no tables under it or is the library name not showing at all? If it is not showing at all your metadata security is probably not set up correctly. Please confirm which of these is the case. 

Super Contributor
Super Contributor
Posts: 340

Re: library not available to see for users

Thanks SASKIWI for shadowing this up. I think security on the folder is fine but somehow library is not showing up in EG server list, so in this case - cause 2 scenario comes in picture from your explaination. - what are the things need to make sure?

Thanks!

Super User
Posts: 3,235

Re: library not available to see for users

Setting up the correct security/permissions in SAS BI Server is a major topic. I think the best I can do for now is point you at an excellent paper that helped de-mystify this for me:

http://support.sas.com/resources/papers/proceedings11/376-2011.pdf

The key to setting up security is to understand how metadata folders work - these are not the same as physical disk folders. At it's simplest you could set up a metadata folder called Share, then when you create a SAS data library, say called TEST, in metadata you store it in the Share folder. For users to be able to see TEST they must have permissions to read the Share metadata folder. The paper explains it much better than me.

Respected Advisor
Posts: 4,135

Re: library not available to see for users

The correct metadata security settings will be the one part to make this work, a correct libname statement the other one. If the libname statement is not valid for a pre-assigned library (eg: the user does not have access to the path defined in the libname definition) then the library won't show up in EG. You should see in the server log that there was an error though.

Valued Guide
Posts: 3,208

Re: library not available to see for users

Settting up security as a "good practice" is a more challenging topic.

I would like to know how the “bisecag” and “best practices according Denmarks SAS office” is used and understood. This is related to a well defined security concept.    What is your approach?

http://www.linkedin.com/groupItem?view=&gid=70702&type=member&item=275517448&qid=bb5347ef-fa26-474c-...  

---->-- ja karman --<-----
Super Contributor
Super Contributor
Posts: 340

Re: library not available to see for users

thanks all!

Respected Advisor
Posts: 4,135

Re: library not available to see for users

So... what was the cause of the issue and how did you resolve it?

Super Contributor
Super Contributor
Posts: 340

Re: library not available to see for users

Administrator told me that he and security team came up with shared folder security issue, they resolve it somehow and library is available now...still i didn't see any significant change in new library and have same parameters as i mentioned in my questions,

engine=base

pre-assigned

path=share drive path on local machine

assign=sasmain

public/sas system services: authorization= RM/CIM/WM (indirect permission)

administrator authorization: everything (indirect permission)

Thanks all for sharing information...

Super Contributor
Super Contributor
Posts: 340

Re: library not available to see for users

I also gave try and was able to create library through tools > sas eg explorer with assigned more -2 and then preassigned from SAS MC... working fine right now...

Thanks All!!!! Smiley Happy

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 11 replies
  • 2537 views
  • 4 likes
  • 4 in conversation