Desktop productivity for business analysts and programmers

how to enable/allow XCMD command for 9.1?

Accepted Solution Solved
Reply
Regular Contributor
Posts: 220
Accepted Solution

how to enable/allow XCMD command for 9.1?

Hi Friends - we are using SAS 9.1 on windows and when submitting x command in EG getting below warning message.

WARNING: Shell escape is not valid in this SAS session. We have troubleshoot available for 9.2 or later o google but didn't find for 9.1...

how to do it? - please help!

Thanks!


Accepted Solutions
Solution
‎12-27-2013 12:07 PM
PROC Star
Posts: 1,146

Re: how to enable/allow XCMD command for 9.1?

Well, you have two options:

1. Convince your admin to allow x commands; don't be surprised if the answer's "no".

2. Get your bat files working, and use the Enterprise Guide facilities to send your email (I haven't used it, but you can send emails as part of an EG project).

That's about all you've got, I'm afraid.

Tom

View solution in original post


All Replies
PROC Star
Posts: 1,146

Re: how to enable/allow XCMD command for 9.1?

If you're using the SAS software instance on your PC (check that the profile indicator bottom right of your EG screen says "No profile selected"), you can supply an -xcmd parameter in your sas configuration file.

If you're using a profile, which means you're using a SAS instance on a server, the use of x commands is prohibited by default. This is because breaking out to an O/S shell gives you the ability to mess up the server for all of the users.

Your options are limited. You can request that the prohibition be lifted, but I never say yes when people request it from me. Or you can find a way inside of SAS to accomplish what you need. What are you trying to do with your x command?

Tom

Regular Contributor
Posts: 220

Re: how to enable/allow XCMD command for 9.1?

Hi Tom -

Thanks for your information. I am trying to copy some mdb files from SAS prod server to some share drives for some users. We are having bat file which does this task but its not performing well for some reason so i want to use x command in EG 4.1 with SAS 9.1.3 and i also wants to set up email alert with SAS code rather than BAT code just in case if transfer doesn't happen...

Thanks!

Valued Guide
Posts: 3,208

Re: how to enable/allow XCMD command for 9.1?

Sandy,

When you are asking about SAS PC 9.1.3 remember this is MS-XP bound as is SAS EG 4.1 with .Net 1.1

As it is a local-server definition int the Windows registry it can be changed there. it is rather old. 2009...

Using the X and SYSTASK commands from SAS Enterprise Guide - The SAS Dummy

What you can do with that is using that bat file from  SAS. But as you have problems with that performance (firewalls? network?) it will not improve that.

I would advise to use the pipe command for x-processing. It starts and catches output (being synchronized processing). By that you can trigger an email

For email usage in batch with Eguide yuo should use SMTP as the default of EGUIDE is processing to your local machine mail-program.

---->-- ja karman --<-----
Solution
‎12-27-2013 12:07 PM
PROC Star
Posts: 1,146

Re: how to enable/allow XCMD command for 9.1?

Well, you have two options:

1. Convince your admin to allow x commands; don't be surprised if the answer's "no".

2. Get your bat files working, and use the Enterprise Guide facilities to send your email (I haven't used it, but you can send emails as part of an EG project).

That's about all you've got, I'm afraid.

Tom

Regular Contributor
Posts: 220

Re: how to enable/allow XCMD command for 9.1?

Thanks Tom and Jaap.

I will check on both options....

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 5 replies
  • 1246 views
  • 3 likes
  • 3 in conversation