Desktop productivity for business analysts and programmers

how to avoid forever "collecting" status?

Reply
Frequent Contributor
Posts: 128

how to avoid forever "collecting" status?

I just started using Enterprise Guide for a couple weeks.

I noticed that my SAS enterprise guide 4.3 was frozen several times with a "collecting" status at the bottom of the enterprise guide windows.

I tested my programs on SAS 9.3, and they run correctly. And I also tested all the same programs on SAS enterprise 4.3 step by step separately, and they run just fine.

But if I tried to run from step1 to the last step by choosing "run from step1" then the whole Enterprise Guide 4.3 would be frozen somewhere for ever with a "collecting" status.

I installed "Integration Technologies Client 9.3", as SAS help suggested, but I don't know how to configure the Integration Technologies Client 9.3.

44627 - Performance is slow when SAS® Enterprise Guide® is collecting results

Any easier way to fix this? Thanks!

Respected Advisor
Posts: 3,065

Re: how to avoid forever "collecting" status?

I've found it helpful to set the maximum number of datasets added to project to 0 under Tools, Options, Results General. If your project is creating lots of datasets this can speed up the Collecting phase. You can still find the datasets in the Server window.

Frequent Contributor
Posts: 128

Re: how to avoid forever "collecting" status?

, thanks for the addvice. I tried what you suggested, but still, I got the same "collecting" status. Smiley Sad I also tried to set the maximum to 100, it did not work either.

Frequent Contributor
Posts: 128

Re: how to avoid forever "collecting" status?

I tried the following options:

in tab "tools":

result -> results generral, I left the following boxes empty:

[ ] replace without prompting

[ ] show generated wrapper code

[ ] automatically open data or results

[ ] link handcoded ods result

then, set report to 'text' only

and

data -> data generral

[ ] automatically open data when added to project.

then I did have high probability to run my enterprise successfully without getting the "collecting" message. (from 0% before to now 10%, roughly, lol).

I have SAS 9.3 installed, can I upgrade my SAS enterprise guide from 4.3 to 5.1? It seems there is no way to fix this "collecting status" issue in 4.3.

Respected Advisor
Posts: 3,065

Re: how to avoid forever "collecting" status?

Have you checked out Windows Task Manager while EG is collecting? What memory and CPU usage is EG using?. Are you maxing out on CPU and/or memory?

Are you running on a remote or local (your PC) SAS server? A local server will definitely use more resources.

EG 5.1 is a worthwhile upgrade - this is the version we use with SAS 9.3.

Frequent Contributor
Posts: 128

Re: how to avoid forever "collecting" status?

,

I am running a local PC with SAS 9.3 installed.

I do use Windows Task Manager. Actually, have to say, I need to keep Task Manager open while I am using EG 4.3, because I have to use it to force-close my always frozen EG. The stop function in EG does not work at all.

In the task manager, I also have to force-close all running sas.exe after force-closing EG. Otherwise, my pc would run out of memories.

I just find that if I zoom in/out my "Process Flow" window while the EG is running the programs, I will definitely make my EG frozen. If I do not touch anything after clicking "run branch from XXX" then I will probably, not 100%, have my EG successfully run.


By the way, where/how can I upgrade to EG 5.1?


Thanks SASKiwi!

Respected Advisor
Posts: 3,065

Re: how to avoid forever "collecting" status?

To upgrade I would check with your SAS account manager - a SAS software request is probably required.

Also are there other SAS users in your organisation and do they have the same problem? If not it may a PC specific issue.

Suggest you also raise a Tech Support track with SAS as they can check out your problem much more thoroughly. I've had SAS Tech Support remote in to my PC to resolve really gnarly problems and that can be very useful.

Contributor
Posts: 71

Re: how to avoid forever "collecting" status?

Are you generating reports using ODS?

I have an EG project that generated hundreds of Excel reports using ODS ExcelXP. After creating the reports, EG would freeze while it dealt with the reports....not sure what it was doing, linking them or something like that. This could take 5-10 mins, regardless of the EG option settings mentioned above. I tried everything. From memory, I think the task status was "Collecting..." too.

Anyway, I found that the following ODS statement stopped this behaviour dead in its tracks:

ods noresults;

This was fortunate, because in a few days I had to handover the running of the project to a non-IT business customer. Having EG freeze while it churned through ODS results would have been less than ideal.

Ask a Question
Discussion stats
  • 7 replies
  • 1971 views
  • 1 like
  • 3 in conversation