Desktop productivity for business analysts and programmers

export txt file with delimiter semicolon

Accepted Solution Solved
Reply
New Contributor
Posts: 4
Accepted Solution

export txt file with delimiter semicolon

[ Edited ]

Hi,

 

I would like to export a txt file with semicolon instead a comma, is it possible to do this without procedure?  Are there any place in configuration where i can change the default comma to semicolon?

 The question is for SAS enterprise guide

 

 

Thank you very much

Maria


Accepted Solutions
Solution
‎10-25-2017 05:44 AM
Super User
Posts: 20,203

Re: export txt file with delimiter semicolon

I couldn't see anything in the GUI, but I would expect it to be there somewhere....

 

Otherwise, a proc export is straighforward, just change the path. However, if EG is on the server you can't export directly to your local drive, so that's a downside. Hopefully someone else has a better answer!

 

proc export data=sashelp.air outfile='c:\_localdata\temp\test.txt' dbms=dlm replace;
delimiter=';'; 
run;

View solution in original post


All Replies
Solution
‎10-25-2017 05:44 AM
Super User
Posts: 20,203

Re: export txt file with delimiter semicolon

I couldn't see anything in the GUI, but I would expect it to be there somewhere....

 

Otherwise, a proc export is straighforward, just change the path. However, if EG is on the server you can't export directly to your local drive, so that's a downside. Hopefully someone else has a better answer!

 

proc export data=sashelp.air outfile='c:\_localdata\temp\test.txt' dbms=dlm replace;
delimiter=';'; 
run;
Super Contributor
Posts: 349

Re: export txt file with delimiter semicolon

With EG 7.12x select "Text Files"

 

csv_export_colon.png

SAS Employee
Posts: 129

Re: export txt file with delimiter semicolon

Hi @mcnunes

 

As mentioned by @Reeza, proc export is an easy option to get what you're looking for.

But if you want to use the export mentioned by @andreas_lds, you ahve to be aware that the delimiter (comma or semicolon) will be delimited by the Region and Language settings, in particular the Format one.

 

If you select French for instance on your local machine (where SAS Enterprise Guide is installed), you'll have the semicolon.

RegionAndLanguage.JPG

But if you have English, comma will be your delimiter.

 

Changing that setting may have too much impact on your machine.

So an easy alternative would be to add the /culture:fr parameter to your EG shortcut

 

Your new TARGET value would look like this:

  D:\opt\sasinside\SASHome\SASEnterpriseGuide\7.1\SEGuide.exe /culture:fr

Culture.JPG

 

Hope that helps.

 

Cheers,
Damo

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 221 views
  • 3 likes
  • 4 in conversation