Desktop productivity for business analysts and programmers

Warning about HtmlBlue style when using EG 7.1

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 10
Accepted Solution

Warning about HtmlBlue style when using EG 7.1

I get this warning: 

WARNING: Style HTMLBLUE not found; Default style will be used instead.

 

I get this only when using EG 7.1 on a server with SAS 9.2 installed, not when on a server with 9.4 and not when using EG 6.1 on any server. I know that the .css file exists in my install folder and the SAS report actually still displays correctly with HtmlBlue even when I get the warning.

 

Does anybody know what would cause this?


Accepted Solutions
Solution
‎03-02-2016 03:49 PM
Community Manager
Posts: 2,889

Re: Warning about HtmlBlue style when using EG 7.1

Yes, you have the opposite problem that I discussed here.

 

HTMLBLUE is defined in SAS 9.3 and later as a server-side style, with an official ODS style template.  But it's not in 9.2, which is why you have the error when EG generates a STYLE=HTMLBLUE option.

 

You can add a "token" HTMLBLUE style to the server with PROC TEMPLATE with something like:

 

proc template;
   define style htmlblue;
   parent=styles.default;
   end;
run;

Or...simply choose a different style that exists in 9.2 (like BarretsBlue).

View solution in original post


All Replies
Solution
‎03-02-2016 03:49 PM
Community Manager
Posts: 2,889

Re: Warning about HtmlBlue style when using EG 7.1

Yes, you have the opposite problem that I discussed here.

 

HTMLBLUE is defined in SAS 9.3 and later as a server-side style, with an official ODS style template.  But it's not in 9.2, which is why you have the error when EG generates a STYLE=HTMLBLUE option.

 

You can add a "token" HTMLBLUE style to the server with PROC TEMPLATE with something like:

 

proc template;
   define style htmlblue;
   parent=styles.default;
   end;
run;

Or...simply choose a different style that exists in 9.2 (like BarretsBlue).

Occasional Contributor
Posts: 10

Re: Warning about HtmlBlue style when using EG 7.1

Thank you!
☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 659 views
  • 2 likes
  • 2 in conversation