Desktop productivity for business analysts and programmers

WHY WON'T MY AXIS STATEMENT IN PROC GCHART WORK?

Reply
Contributor
Posts: 50

WHY WON'T MY AXIS STATEMENT IN PROC GCHART WORK?

It runs fine (apparently according to the log) and outputs but the axis doesn't follow any of my specs.

CODING:

PROC GCHART DATA=WORK.MASTER_SET1;

  VBAR MAP_PN_1 / TYPE=PERCENT LEVELS=50;

  AXIS1 ORDER = (0 TO 25000 BY 5000)LABEL=(A=90 'X-AXIS');

RUN;

QUIT;

LOG WHEN I RUN IT:

470  TITLE "Distribution of Maternal Age at Time of Birth";

471  PROC SGPLOT DATA=WORK.MASTER_SET1;

472      HISTOGRAM MAP_PN_1 / SCALE=PERCENT;

473          XAXIS VALUES=(0 TO 25000 BY 250);

474          INSET "THIS IS THE INSET" / BORDER POSITION=topright;

475          XAXIS LABEL="Mean Average Payment per Patient for PN DRG ($)";

476  RUN;

NOTE: PROCEDURE SGPLOT used (Total process time):

      real time           0.36 seconds

      cpu time            0.15 seconds

NOTE: Listing image output written to SGPlot2.png.

NOTE: There were 4826 observations read from the data set WORK.MASTER_SET1.

477  QUIT;

Trusted Advisor
Posts: 2,114

Re: WHY WON'T MY AXIS STATEMENT IN PROC GCHART WORK?

Your log does not match your code. 

Trusted Advisor
Posts: 2,114

Re: WHY WON'T MY AXIS STATEMENT IN PROC GCHART WORK?

In SGPLOT, I think that you can only have one XAXIS statement.

In GCHART, I think that you need a space before the keyword LABEL.

Ask a Question
Discussion stats
  • 2 replies
  • 220 views
  • 0 likes
  • 2 in conversation