Desktop productivity for business analysts and programmers

Unable to connect to the metadata server in SAS EG 7.1

Reply
Contributor
Posts: 27

Unable to connect to the metadata server in SAS EG 7.1

Hi Team

We have recently migrated from SAS EG 4.1 to SAS EG 7.1.

I have seen a thread with the same issue, but couldn't get much help from it. Hence starting new  thread.

One of the user is getting the error "Unable to connect to the metadata server" when she is trying to "SET ACTIVE" the profile.

The message did ask me to check few things and none of them matched to the issue.

I have attached the screenshot for your reference,

Request you to kindly advice.

Thanks

Raj

Attachment
SAS Employee
Posts: 3

Re: Unable to connect to the metadata server in SAS EG 7.1

Hi Raj,

The best first step is to try the connection using the SAS Integration Technologies Configuration tool. To do that, follow these steps:

1. Start -> All Programs -> SAS -> Utilities -> SAS Integration Technologies Configuration

2. After the wizard displays, select "Test SAS Servers" if it is not already selected.  Then click Next.

3. On the "Choose How to Test" page, select "Enter a SAS Server definition manually" if it is not already selected. Then click Next.

4. On the SAS Server page, change the "Currently Testing" to say "SAS Metadata Server".

- Enter the host name in the Machine NAme field.

- Enter the metadata server port in the port field.

- If the profile in EG is set to use a user/pw, enter those.

- If the profile in EG is set to use IWA, then change the Security Package to be Negotiate and do not change the SPN and Package List fields.

5. Click Test.

If the test succeeds, then double check that the exact same information is entered in the EG profile. If it is, I recommend contacting Technical Support.

If the test fails, click details, and copy the description text to here. Don't copy the full details!! There may be sensitive information there that you don't want posted on this forum!!

SAS Super FREQ
Posts: 270

Re: Unable to connect to the metadata server in SAS EG 7.1

UPDATE: Whoops, I see Mark beat me to it.  Glad we had the same thing to say!

As a test, Tech Support would likely have you try connecting to the metadata server from the same machine using the SAS Integration Technologies Configuration Wizard (located here: C:\Program Files\SASHome\x86\Integration Technologies\ITConfig2.exe).  Click Test SAS Servers, Enter a SAS server definition manually, select SAS Metadata Server, enter the machine name of the host where your metadata server is running (same as in the EG profile), change port to 8561 (or the appropriate port of your metadata server -- same as in EG profile), and enter the same credentials used in the EG profile, then click Test.  If you can't make a connection from SAS Integration Technologies Configuration Wizard using the same connection information, then you won't be able to in EG either (EG uses Integration Technologies to connect to servers).  Check to make sure you entered the correct host and port of your metadata server.  Also, make sure you can ping the metadata server host from the client host.  If you aren't able to resolve, I recommend opening a ticket with Tech Support.

Contributor
Posts: 27

Re: Unable to connect to the metadata server in SAS EG 7.1

Hi Casey/Mark

We use the SAS applications which are ThinApp'ed. So, if the applications are Thinapp'ed we won't be able to test the server connections functionality. It is only one user who is facing this issue and not sure what is stopping her from connecting to the profile.

Request you to advice.

Thanks

Raj

SAS Employee
Posts: 3

Re: Unable to connect to the metadata server in SAS EG 7.1

Raj,

If you are unable to access the Integration Technologies Configuraiton tool, I recommend contacting Technical Support. They can help you diagnose the issue.

Mark

Contributor
Posts: 27

Re: Unable to connect to the metadata server in SAS EG 7.1

Hi Mark

Thanks.

I have raised a ticket with SAS and see what they would suggest.

Will update you on the outcome of this issue.

@ Casey - Thanks to you as well for the prompt response.

Thanks

Raj

Esteemed Advisor
Posts: 6,641

Re: Unable to connect to the metadata server in SAS EG 7.1

Stupid question: have you verified her credentials on the server? (SSH or anything similar)

And check the metadata server log.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
Contributor
Posts: 27

Re: Unable to connect to the metadata server in SAS EG 7.1

Hi Kurt

Apologies if my question was stupid, but I am new to SAS Administration.

I have checked the credentials on SAS server and it is fine. I have checked the Metadata Logs and log says " UFNE The requested user folder 'My Folder' does not exist for user" ..... but I can see that a "My Folder" was created for that user in Management console.

Please let me know if there is any other place that I can check.

Thanks

Raj

Grand Advisor
Posts: 10,196

Re: Unable to connect to the metadata server in SAS EG 7.1

I don't believe Kurt implied your question was stupid. It was more of a "this is something you probably already did but I'm asking just to cover all of the bases". Sort of like "Is the TV plugged in" as an early step in troubleshooting that is sometimes skipped.

Contributor
Posts: 27

Re: Unable to connect to the metadata server in SAS EG 7.1

Hi Ballard

got it .... Smiley Happy

Thanks

Raj

Contributor
Posts: 27

Re: Unable to connect to the metadata server in SAS EG 7.1

Hi Team

Do you have any other suggestions. I am still stuck with this one.

Raised a ticket with SAS and awaiting their reply.

Thanks

Raj.

Respected Advisor
Posts: 3,060

Re: Unable to connect to the metadata server in SAS EG 7.1

How do you authenticate in the connection profile, by putting in a username/password or use Windows authentication? If you use a username/password, try a different one, for example your own as you know that works on your own PC.

Contributor
Posts: 27

Re: Unable to connect to the metadata server in SAS EG 7.1

Hi All

I thank you for your valuable suggestion.

Finally, we were able to identify the resolution for this issue.

As mentioned that  our SAS applications are ThinApp'ed. So there was a problem with user settings and the sandbox properties are getting created/stored properly for the users. The server team has identified the issue and it is NOT a SAS issue.

The users AD profile has been recreated and all seems to work fine now.

Thanks

Raj

Occasional Contributor
Posts: 5

Re: Unable to connect to the metadata server in SAS EG 7.1

Hi Anyone I have the problem with SAS Enterprise guide 7.1 connectivity. with the same guy below.

I have tried the testing through mentioned steps below but still i cannot connect.

Contributor
Posts: 72

Re: Unable to connect to the metadata server in SAS EG 7.1

If you are still getting the same error message after testing via the SAS Integration Technologies Configuration Wizard. Try to ping the port for SAS Metadata server and see if you are able to reach it.

 

Start -> RUN -> CMD -> telnet <metadataserverhostname> <metadataserverportno>

 

Note: Please try this step only after you have tested the previous things.

I had faced this issue when few users on a floor were not able to connect & finally we could see that their VLAN was not a part of the network and they couldn't even reach the port.

 

Thanks

Anand!

 

Ask a Question
Discussion stats
  • 14 replies
  • 5498 views
  • 0 likes
  • 8 in conversation